View Issue Details

IDProjectCategoryView StatusLast Update
0009576Multi Theft Auto : San AndreasSecuritypublic2017-06-29 00:49
ReporterALBANDER Assigned Toccw  
Status resolvedResolutionfixed 
Product Version1.5.3 
Target Version1.5.4Fixed in Version1.5.4 
Summary0009576: SD # 31 , SD # 32 Not Working Propely !

Hi ,

i have tried in Gta-Ar : mtasa://

autohotkey script

if i make autohotkey script and inject keyboard input

the server not kick me

but if i Compile script (from .ahk to .exe)

the server kick me "SD #4 LNK"

i can reproduce this bug

TagsNo tags attached.



2017-03-25 17:19

viewer   ~~0025755

It doesn't kick you, it just blocks it.


2017-03-25 17:33

viewer   ~~0025756

Last edited: 2017-03-25 17:34

No , see :

SD #31 1.5.3 1.5.3-9.11204 Disallow injected keyboard inputs

(e.g. from AutoHotKey and other key macro programs)

SD #32 1.5.3 1.5.3-9.11204 Disallow injected mouse button inputs

also , i tried speed hack using F3 , SPACE

The server not do anything !

Link :

To use : switch on/off F3 , Hold SPACE


2017-03-25 20:24

administrator   ~~0025757

Is this just the SPACE key?


2017-03-25 20:33

viewer   ~~0025758

Last edited: 2017-03-25 21:33

if you start the hack , the hack tell you what you do

SD # 31 , SD # 32 Are not working

i tried autohotkey & speedhack in my local server with enablesd : 31 , 32

the server didn't kicked me

but only if i compile .ahk to .exe the server kick me SD #4 LNK

Please Fix the problem (not for autohotkey and speed hack only , there is more and more programs to inject keyboard and mouse inputs !)


2017-03-25 22:58

administrator   ~~0025760

SPACE should be ignored now.
I've updated the wiki to show that SD 31+32 means that keys are ignored

Issue History

Date Modified Username Field Change