View Issue Details

IDProjectCategoryView StatusLast Update
0009248New issuesClientpublic2016-05-26 17:08
Reporterharon4igg Assigned ToDutchman101  
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionduplicate 
Summary0009248: MTA Crashes
Description

Hello,

Me and my players faced a problem with MTA crashes... I tried a lot of different stuff to understand why its happening, but without any success.

I received a few crash logs from my players and i need help with de-symbolication of this logs.

Any help will be appreciated, what ever you tell me what happened there, which file/line of mta source code, or how i can de-symbolicate it manually

Thanks in Advance.

TagsNo tags attached.

Relationships

duplicate of 0009163 resolvedccw Multi Theft Auto : San Andreas setElementModel crash 

Activities

ccw

2016-05-25 00:50

administrator   ~~0024708

The game_sa.dll crashes are caused during a model replace. Your players should get a message (when MTA is restarted) saying which model ID was causing the problem.

haron4igg

2016-05-25 07:03

viewer   ~~0024709

Yes, this crash is appears only during loading, if you was reconnecting to the same server few times (looks like memory leak). And the object id is always different.

What about this one with proxy_sa and game_sa? It appears during gameplay really often and annoying to players, just receive the new logs(

Version = 1.5.2-release-7985.0.000
Time = Tue May 24 22:10:22 2016
Module = D:\GTA San Andreas\proxy_sa.exe
Code = 0xC0000005
Offset = 0x00133EA9

EAX=00000000 EBX=00AB4694 ECX=1E9E60A8 EDX=0C204085 ESI=1E9E60A8
EDI=00AB4694 EBP=00000000 ESP=0177FB6C EIP=00533EA9 FLG=00210202
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

-- End of unhandled exception --

-- Unhandled exception --

Version = 1.5.2-release-7985.0.000
Time = Sun May 22 23:54:04 2016
Module = D:\GTAMT'A\gta_sa.exe
Code = 0xC0000005
Offset = 0x000096AD

EAX=264B9268 EBX=00AB2A74 ECX=264B9268 EDX=00863C40 ESI=264A2EBC
EDI=00AB2A74 EBP=00000000 ESP=0022FB68 EIP=49646550 FLG=00010246
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

-- End of unhandled exception --

-- Unhandled exception --

Version = 1.5.2-release-7985.0.000
Time = Mon May 23 14:01:04 2016
Module = D:\GTAMT'A\gta_sa.exe
Code = 0xC0000005
Offset = 0x00133EA9

EAX=00000000 EBX=00AB1C14 ECX=220B8A5C EDX=08004085 ESI=220B8A5C
EDI=00AB1C14 EBP=00000000 ESP=0022FB74 EIP=00533EA9 FLG=00010202
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

-- End of unhandled exception --

Dutchman101

2016-05-25 18:19

updater   ~~0024710

Last edited: 2016-05-25 18:22

haron4igg, the crashes in your last comment are know, see: https://mantis.mtasa.com/view.php?id=9163
(0x000096AD and 0x00133EA9)

for details. If you stop using such scripts that are known to trigger it - your players will likely stop experiencing them.

You seem like yet another scripter that tends to develop their scripts in a manner that makes them prone to crash clients, in some ways yet to be investigated.

Dutchman101

2016-05-25 18:24

updater   ~~0024711

Is it true that you're using setElementModel, and even more specific: setElementModel(projectile) ?

haron4igg

2016-05-25 18:34

viewer   ~~0024712

Just found out this bug a hour ago and removed all logic using setElementModel for projectile))
This issue can be closed as duplicated i guess.

Thank you anyway:)

Issue History

Date Modified Username Field Change