View Issue Details

IDProjectCategoryView StatusLast Update
0009221New issuesMovementpublic2018-09-30 12:11
ReporterGreenlanderAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Platform64-bitOSWindowsOS Version10 Pro
Summary0009221: Slightly faster car speed
Description

Well after beeing accused of "speedhacking" I noticed I'm driving faster than anyone else.
I thought it might be cause I locked my game fps with fps_limit to 51 fps and the server got a max rate of 53 fps. but after I removed my fps lock and tested it with some random guy again I still got no problem to overtake him (when accelerating as well as on full speed). It's like driving with 110% of the max speed though it doesn't feel weird.
only other thing I changed lately was to enable nvidia's shadowplay game capture to run in the background.
Still the same after I deactivated it.
Hope we can find the reason for this since it's quite an unfair advantage, especially in time based gamemodes.

Additional Information

If needed I could record it for better explanation.

TagsNo tags attached.

Activities

AlexTMjugador

2016-04-19 17:20

viewer   ~~0024627

Do both clients run at the same gamespeed? And, more importantly, does the server you play on modify the gamespeed under certain circumstances?

If your gamespeed is higher than the one other clients play the game with, you can easily conclude what is causing the issue. Furthermore, if the server you play on has a bugged gamespeed-changing script, you can be (almost) 100% sure that is the source of the issue.

Greenlander

2016-04-19 17:29

viewer   ~~0024628

Last edited: 2016-04-19 17:32

View 2 revisions

Well it's not just on that server. It's on every I tried.
How do I check if my gamespeed changed and how do I change it back?

Edit: Yes some deathmatch got gamespeed changing scripts included

AlexTMjugador

2016-04-19 17:41

viewer   ~~0024629

Last edited: 2016-04-19 17:44

View 2 revisions

The easiest method to check if your gamespeed changed, providing that you can't get the value that getGameSpeed() returns in your client, is to compare more speeds with another clients: running speed, swimming speed, animation speed, clock speed...

Greenlander

2016-04-19 18:17

viewer   ~~0024630

But why wouldn't my gamespeed reset to 1.0 after a server reconnect or even a game restart?

qaisjp

2016-04-19 18:50

administrator   ~~0024631

It should reset.

Greenlander

2016-04-19 18:53

viewer   ~~0024632

aye

btw the clock speed seems to be unchanged since I was able to make a 3 seconds faster toptime on a DM map without struggle

AlexTMjugador

2016-04-19 19:11

viewer   ~~0024633

I was talking about GTA's clock, the one that reflects the time of the in-game day and is influenced by setMinuteDuration and gamespeed. Obviously scripts which rely on real time calculations by using getTickCount or getRealTime will work fine, independently from the gamespeed.

ccw

2016-04-19 20:18

administrator   ~~0024634

Download and run this:
https://nightly.mtasa.com/files/temp/TimeDriftTest.exe

The copy the content of TimeDriftTest.log to
https://pastebin.mtasa.com/

LooooP

2016-04-20 13:04

reporter   ~~0024638

Let me ask you a dumb question: Is your GPU/CPU overclocked?

Greenlander

2016-04-20 15:07

viewer   ~~0024639

so here are my results @CCW

https://pastebin.mtasa.com/322954682

@LooooP no. neither my GPU nor my CPU is overclocked

ccw

2016-04-21 13:03

administrator   ~~0024641

Download, extract and run https://nightly.mtasa.com/files/MTADiag.zip and follow the instructions.

Press 'n' when asked.

Post any Pastebin URL MTADiag gives you.

Greenlander

2016-04-21 15:38

viewer   ~~0024642

Alright. These are my results

https://pastebin.mtasa.com/298992843

ccw

2016-04-22 20:45

administrator   ~~0024645

Thanks. Now connect to this server and stay connected for 5 mins:
mtasa://178.32.44.73:22003

Greenlander

2016-04-22 21:39

viewer   ~~0024646

done so far

ccw

2016-04-22 22:31

administrator   ~~0024647

Your client gained an extra 8120 ticks compared to the server. So it seems something in your PC is running fast by 2.7%
Is the time always accurate?

Greenlander

2016-04-23 08:08

viewer   ~~0024648

Hm strange
what time do you mean exactly? the local time on my pc? yes it's always accurate. At least now that I compared it to my mobile phone clock.
But I remember I used /time ingame once and it was already like 18:09:30 while others assured me it's just 18:08:XX for them

Greenlander

2016-04-23 11:39

viewer   ~~0024649

Last edited: 2016-04-23 12:19

View 4 revisions

Had a look on my computer clock and compared the seconds with my mobile phone. and indeed after just 1 minute i had already a difference of round about 2 seconds

I just never noticed that since my clock synchronizes via internet

Edit: ok it's getting weirder. I went into my bios to check if there is a time drift aswell but nothing. it was always in sync with my phone. after i restarted my pc the time drift in windows seems to be gone aswell.
Already checked it ingame. Now I'm driving as fast as everyone else. No idea what caused it yet since I actually didnt change anything

Issue History

Date Modified Username Field Change