View Issue Details

IDProjectCategoryView StatusLast Update
0009031Multi Theft Auto : San AndreasSynchronizationpublic2016-12-04 08:01
ReporterGrafuAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version10 Pro
Product Version 
Target VersionFixed in Version 
Summary0009031: Player team desync has been introduced with recent revisions
Description

Since last week, after auto updating MTA client, I've started experiencing an issue where you set the player team serverside and the client sometimes doesn't get updated. It used to be fine before.

Steps To Reproduce

Not known.

TagsNo tags attached.

Activities

ccw

2015-09-08 15:45

administrator   ~~0024064

Could it be #8053 Team members are not fully synced clientside when joined

Grafu

2015-09-09 06:42

viewer   ~~0024065

I am not sure. I've noticed an occasion where I set the player team on his login to the account, it gets set serverside, but doesn't refresh for remote players. As far as I remember this started happening last week after forced clienr update.

ccw

2015-09-09 12:48

administrator   ~~0024066

No changes to the team code have been made recently. Is the player dead when he logs in? Because #8053 can occur for dead players when other players join.

Grafu

2015-09-09 12:59

viewer   ~~0024067

Last edited: 2015-09-10 19:33

View 3 revisions

I'm not sure. I'll try to better investigate this.

EDIT: Yeah, the player is dead and it's http://bugs.mtasa.com/view.php?id=8053 . It confirms that nothing has been changed in the team code, but now I am wondering how that person didn't spawn at all while he was following the same logic as others.

EDIT2: Not sure how to describe this one: http://i.imgur.com/c87t7GG.png . Looks like it fails to spawn the player on freshly joined remote clients. The player was alive and playing fine, but my client showed him dead stuck at 0, 0, 0 map center coordinates.

ccw

2015-09-16 02:23

administrator   ~~0024088

Please try latest nightly r7523

Grafu

2015-09-16 13:08

viewer   ~~0024089

I guess my issue is not even team related. Something weird happens with spawnPlayer. Like I last time described it, I joined the server, warped the player, who was not in the team (he was not inside, because he wasn't spawned on my client). But the server was reporting him spawned, alive and moving in some town. But when I warped him using AP, there was no player visible at all. /crun getElementPosition was returning 0, 0, 0 (just like he wasn't correctly spawned), but /srun was returning correct position coordinates.

ccw

2015-09-16 13:59

administrator   ~~0024090

For each player, please check that:
onPlayerSpawn is triggered on the server.
onClientPlayerSpawn is triggered on all clients.

Grafu

2015-09-16 14:04

viewer   ~~0024091

Last edited: 2015-09-18 12:14

View 3 revisions

Okay, I found the issue. It's related to http://bugs.mtasa.com/view.php?id=8053 . Not only teams get desynced, but also many other details like ping, death state, position etc.

Steps to reproduce:

  1. Kill a player. Don't respawn it
  2. /reconnect
  3. Warp the dead player, /crun isPedDead(player) will return true while /srun returns false
    /crun getPlayerPing(player) will return 0 while /srun will return the normal ping etc.

einheit-101

2016-11-30 21:30

reporter   ~~0025450

Bump. Grafu is right. Sometimes isPedDead returns TRUE client side, but false server side. This bugs a lot sometimes.

ccw

2016-11-30 21:47

administrator   ~~0025452

Player team desync is fixed. New issues for other problems.

einheit-101

2016-11-30 22:11

reporter   ~~0025453

Ooops just googled this issue and didnt see it was marked as resolved. Going to open a new one.

Issue History

Date Modified Username Field Change