View Issue Details

IDProjectCategoryView StatusLast Update
0008967Multi Theft Auto : San AndreasServerpublic2015-08-14 12:16
ReporterXenius Assigned Tosbx320  
Status resolvedResolutionfixed 
Target Version1.5.1Fixed in Version1.5.1 
Summary0008967: 1.5 server uses a lot of memory after days

0 days:
7 days:

TagsNo tags attached.



2015-07-30 16:59

viewer   ~~0023755

Missed: this is not a script error


2015-07-30 18:57

manager   ~~0023757

I'm having the same problem too actually.

MTA server memory usage constantly goes up and it's even got to 3700 MB which is where my script kicks everyone and restarts the server before it gets to 4 GB and crashes.

Lua VM totals: 469556 KB
Memory used by MTA: 2048 MB.

Whereas it was more like 1000 MB yesterday with the same player count when the server started. After 1 day and 2 hours it's already on 2 GB. In 2 more days it will probably restart again.

Last time I debugged server using loads of memory, ccw sent me a build where the "Lib memory" in performancebrowser has info.


2015-07-30 19:12

updater   ~~0023758

Ok, we are not the only one :)

This is the memory consumption from our linux_x64-1.5.0-rc-7354.
Green is VIRT, blue is RSS.
We changed from 1.4.1 to 1.5 at week 29. The 1.4.1 was running for 41 Days before.
Today, strange things happened, the logic thread was sometimes around 1 fps, also players got network trouble. So we made a cut and updated to linux_x64-1.5.0-rc-7376 today after 12 days uptime. Our scripts are the same as with 1.4.1


2015-07-31 01:50

updater   ~~0023761

I've had the same thing, ~ 1.5gb usage in just one day and it didn't explain in resource (or memory leak) usage.

But after updating server to r7376 64bit the high memory usage came to an abrupt end as it's stable now, this update included server netcode changes, maybe that fixed it. Can someone confirm that with latest build?


2015-07-31 06:25

updater   ~~0023763

Last edited: 2015-07-31 21:20

Seems much better with r7376:
First 24 hours. But it's too early to say.

It was too early:
Same as before.


2015-07-31 22:33

viewer   ~~0023771

I can say that resources usage is fine with r7352 server. Memory usage stays at 282mb after several days, exactly the same results as with 1.4.1. Could be related to a particular function or module/library I guess?


2015-07-31 23:00

updater   ~~0023772

Gallardo9944 Do you use a 32bit or 64 bit server? May be, it's only a 64 bit issue. I think, you need also much connects, we have between 50 and 150 players and...
grep 'CONNECT:' server.log | grep '2015-07-30' | wc -l
5010 <-- "Some" connects :) I think, Arran has much more...


2015-07-31 23:22

viewer   ~~0023773

I'm using 64 bit server, the amount of connections per day:
grep 'CONNECT:' server.log | grep '2015-07-29' | wc -l
grep 'CONNECT:' server.log | grep '2015-07-30' | wc -l
grep 'CONNECT:' server.log | grep '2015-07-31' | wc -l


2015-08-14 08:35

updater   ~~0023923

May be, it's a little bit early, but using 1.5.0-9.07409.0 linux 64 bit since 48 hours and it seems to be fixed (for me) (VM:1673 MB RSS:432 MB, also more than 4000 connects per day)


2015-08-14 12:16

manager   ~~0023924

00:00:07 Plrs: 631 Mem Usage: 1425 MB
12:11:41 Plrs: 571 Mem Usage: 1426 MB

Only 1 MB in 12 hours, definitely fixed.

I'm guessing this fixed it:

Issue History

Date Modified Username Field Change