View Issue Details

IDProjectCategoryView StatusLast Update
0008588Multi Theft Auto : San AndreasServerpublic2015-01-09 19:57
ReporterVestraHD Assigned Toccw  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Summary0008588: Dead Connections Detected (Crashses Entire Server)
Description

I operated a server running 1.4, every 30-60 minutes of constant activity (and minor script issues popping up in console), we get Network Trouble and everything crashes. I've gone through scripts, checked our config file and it's still happening.

Steps To Reproduce
  • Debug MTA Server.exe
  • If already known and issue tied to a config, tell me where it's at
Additional Information

I'd LOVE some help

TagsNo tags attached.

Activities

arranTuna

2014-10-22 12:26

manager   ~~0022193

Last edited: 2014-10-22 12:37

View 2 revisions

MTA SA build number?
Operating system?
Crash dumps?

This might be the same issue but I woke up to find that our server had crashed 30 times during the night:

http://cit2.net/arran/30crashesToday.rar

Build number 6885 (though it's been fine since it was updated a few days ago)

Windows Server 2008 R2. Possibly related but we updated MySQL yesterday though it was fine for 5 hours now suddenly it's crashing every 30 minutes.

StifflersMom

2014-10-22 13:44

updater   ~~0022194

Last edited: 2014-10-22 13:45

View 2 revisions

Same here. OS: Linux x64 multitheftauto_linux_x64-1.4.0-rc-6865-net1D8
First crash at 02:59 (CEST) (funny time...)
This version was running constantly without any problems since more than 4 weeks before.

We changed to multitheftauto_linux_x64-1.4.0-rc-6892-net1D8 tis morning, but the server continues crashing randomly. I'm at work now, but I will provide collected crash dumps later.

TAPL

2014-10-22 13:50

viewer   ~~0022195

My server r6811 (Window) crashed two times today and one time yesterday.

http://upload.mtasa.com/u/255795609/dumps.rar_

arranTuna

2014-10-22 13:54

manager   ~~0022196

9 more crashes, one even with the newest build and an older build:

http://cit2.net/arran/9moreCrashesToday.rar

I've restarted the whole server, checked every log file but there is absolutely nothing about what could be causing it.

Now I've ran a wire shark capture during the crash, time to look through a million packets.

StifflersMom

2014-10-22 14:31

updater   ~~0022197

Seems to be a net issue. We have an unpublic test server with 6865, it's still running without crashes.

Dutchman101

2014-10-22 14:47

updater   ~~0022198

Last edited: 2014-10-22 14:49

View 2 revisions

@StifflersMom, from one of these crashes, it happens at 01ffc736 (net+0x0002c736), so most likely yes, netcode as that stack message indicates

TAPL

2014-10-22 15:38

viewer   ~~0022199

Crashed just now.

http://upload.mtasa.com/u/927336787/newCrash.rar_

arranTuna

2014-10-22 16:03

manager   ~~0022200

http://upload.mtasa.com/u/534468675/51crashes.rar_

51 crashes all from today, not encrypted.

einheit-101

2014-10-22 16:09

reporter   ~~0022201

6892 without any problems for me (but only one player: me alone)

VestraHD

2014-10-22 16:39

viewer   ~~0022202

Windows 2008 R2, will upload dumps later, unknown build. Console outputs no error when crashing

StifflersMom

2014-10-22 17:14

updater   ~~0022203

http://upload.mtasa.com/u/101204818/6crashes.zip_
linux x64 6865 and 6892 crashes, not encryped, the last one is from linux 32bit.

W

2014-10-22 17:31

viewer   ~~0022204

Last edited: 2014-10-22 17:37

View 2 revisions

3 crashes in r6823 linux 32bit:
http://upload.mtasa.com/u/719529527/server_1.4-release-6823_20141022_1332.dmp_
http://upload.mtasa.com/u/370092688/server_1.4-release-6823_20141022_1440.dmp_
http://upload.mtasa.com/u/103174508/server_1.4-release-6823_20141022_1501.dmp_

after upgrading to r6892 crashes stopped. No errors in logs and no 'dead connections detected' - though I can't check mta-server stdout.

edit: right after posting this: http://upload.mtasa.com/u/504143259/server_1.4-release-6892_20141022_1732.dmp_

vEnom.sk

2014-10-22 21:13

viewer   ~~0022205

We have had 13 crashes today, I tried multiple server revisions, 32 and 64 bit. Same problem

http://upload.mtasa.com/u/737802475/server_1.4-release-6892_20141022_1324.dmp_

ccw

2014-10-22 21:43

administrator   ~~0022206

Looks like a bug with ASE to the master server. Luckily, we can fix it here. So, the crashing should stop now.

VestraHD

2014-10-24 02:05

viewer   ~~0022210

Just happened again ccw

Dutchman101

2014-10-24 06:41

updater   ~~0022211

Last edited: 2014-10-24 07:28

View 2 revisions

Then upload a new dump for the last crash, might contain specific info on it now, or can be totally different

Issue History

Date Modified Username Field Change