View Issue Details

IDProjectCategoryView StatusLast Update
0008403Multi Theft Auto : San AndreasVehiclespublic2014-07-31 20:24
ReporterRuuN- Assigned Tosbx320  
Status resolvedResolutionfixed 
Product Version1.4.1 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008403: Vehicle drifting

Sometimes the vehicle are making drift in 1.4 released 30/07. It's random, and this is not only in my server.

I don't know why when i add nitro this "bug" stop.

Steps To Reproduce

I tried make a make a fix script, worked sometimes.

local timer = nil
local currentModel = 0
local lastVeh = nil

addEventHandler("onClientResourceStart", resourceRoot,
function ()
timer = setTimer(checkVehicle, 50, 0)

function checkVehicle()
local veh = getPedOccupiedVehicle(localPlayer)
if (isElement(veh)) then
local flag = false
if (lastVeh ~= veh) then
lastVeh = veh
setTimer(addVehicleUpgrade, 100, 1, veh, 1010)
setTimer(removeVehicleUpgrade, 150, 1, veh, 1010)
flag = true

    local model = getElementModel(veh)
    if (currentModel ~= model) then
        currentModel = model
        setTimer(addVehicleUpgrade, 100, 1, veh, 1010)
        setTimer(removeVehicleUpgrade, 150, 1, veh, 1010)
        flag = true

    if (flag) then
        outputDebugString("DRIFT FIX: Trying fix it.")


TagsNo tags attached.



2014-07-31 08:56

viewer   ~~0021551

Are you somehow changing the vehicle handling when driving it? Any functions affecting vehicle handling? Or just adding nitro?


2014-07-31 09:25

viewer   ~~0021552

I don't change anything in handling, just add nitro, he stop.


2014-07-31 10:28

viewer   ~~0021555

Okay, I've reproduced it. Entered the server and took a vehicle with custom handling. Once entered it instantly started sliding in weird directions. Adding nitro fixed the issue, also when reentered the same vehicle, the bug was no longer reproducible.


2014-07-31 13:41

viewer   ~~0021556

This bug is destroying race servers, It should be major and high priority.


2014-07-31 13:48

viewer   ~~0021557

After some testing, downgrading to an older nightly (before the nos fix?) actually stops this bug from happening. Downgrade to this


2014-07-31 14:15

viewer   ~~0021560

Had a few players complaining about this last night and I was definitely sure we haven't changed the handling in any way.

If it's fixed by what RuuN says, then i'll be using that for the meantime. But the bug seems to come up randomly.


2014-07-31 20:20

administrator   ~~0021577

Caused by my wrong assumption that the default nitro level was 0.0f instead of 1.0f. With 0.0f gta_sa starts to bug around since nitro level is only defined for -1.0f <= fNitroLevel > 0 < fNitroLevel <= 1.0f.

Sorry for the troubles that commit caused.

Fixed in


2014-07-31 20:24

viewer   ~~0021578

Thank you.

Issue History

Date Modified Username Field Change