View Issue Details

IDProjectCategoryView StatusLast Update
0008238Multi Theft Auto : San AndreasServerpublic2014-05-18 23:23
ReporterTosferaAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0008238: guiScrollPaneGetVerticalScrollPosition returns a wrong value
Description

I'm working with 'guiScrollPaneGetVerticalScrollPosition' which doesn't return the value precisely. The wiki says; "Returns a float ranging between 0 and 100, or false otherwise.", I would say that it is 0% at the beginning ( which is true ) but I never reach 100% ( the end always sums up something else while increasing the elements in it ).

Steps To Reproduce

Just move the scrollbar and check the position now and then

Additional Information

I wrote a small script which is using a dxDraw to output the position, you can use it to see what's wrong ( in my eyes, file also attached );
https://dl.dropboxusercontent.com/u/50693175/test-scroll.zip

TagsNo tags attached.

Relationships

duplicate of 0003484 resolvedJusonex guiScrollPaneGetVerticalScrollPosition returns strange and stepped values 

Activities

sbx320

2014-05-18 23:22

administrator   ~~0020915

This was fixed in https://code.google.com/p/mtasa-blue/source/detail?r=4929 but not (yet) backported.

Issue History

Date Modified Username Field Change