View Issue Details

IDProjectCategoryView StatusLast Update
0007854Multi Theft Auto : San AndreasServerpublic2014-06-14 06:25
Reportersocialz Assigned Toccw  
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7 (64-bit)
Target Version1.4Fixed in Version1.4 
Summary0007854: Latest nightly (mtasa-1.3.4-rc-5870-20131009) broke the server application

Apparently the previous nightly build broke the server application. Right after I open up the application, it stops and makes an encrypted dump file, which, well, is encrypted.

I have tried re-installing Multi Theft Auto in a new directory, but it didn't work out. I also tried restarting my computer, but it didn't work neither. I have now installed the earlier nightly build and it works just fine.

Steps To Reproduce
  1. Install the latest nightly build
  2. Try to start the server
  3. Server crashes and generates a dump file
Additional Information

When launching a server from in-game instead, I get this error:
Version = 1.3.4-release-5870.0.000
Time = Thu Oct 10 19:06:41 2013
Module = D:\Program Files (x86)\MTA San Andreas 1.3\server\net.dll
Code = 0xC0000005
Offset = 0x0002C9DD
EAX=000000C8  EBX=00000000  ECX=1436FFFF  EDX=FFFFFFFF  ESI=0678EF78
EDI=00000000  EBP=1434F43C  ESP=1434F420  EIP=1437C9DD  FLG=00010246
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B

There are no errors whatsoever in the server logs after the crash. Only the "MTA Blue server" or so is seen in the console, after that it crashes.

TagsNo tags attached.



2013-10-11 11:24

manager   ~~0019480

The dump files are encrypted so that only an MTA developer can look at them, as sometimes dump files contain sensitive information. Uploading one might be helpful for them in this case.


2013-10-11 11:40

viewer   ~~0019481

@arran: Alright. I wasn't sure if the developers are able to use the encrypted dumps, but as they can, I'll upload it as soon as I get to my computer.


2013-10-11 16:24

administrator   ~~0019482

Fixed in latest nightly


2013-10-11 16:24

viewer   ~~0019483

Latest patch fixed the problem. Server works fine now.

Issue History

Date Modified Username Field Change