View Issue Details

IDProjectCategoryView StatusLast Update
0007805Source patchesServerpublic2013-09-07 11:31
ReportermickdermackAssigned Toccw 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5 
Summary0007805: 64-bit: Compile fixes, crash fix
Description

In the attached patch are:
Compile fix for MTA10_Server/mods/deathmatch/logic/CDatabaseManager.h: typedef of SDbJobId changed to intptr_t
Compile fix for Shared/sdk/SString.h: type of SCharStringRef.uiSize changed to size_t as that's the type Lua expects to be passed to lua_tolstring
Crash fix for Shared/sdk/SharedUtil.Misc.hpp: Check for std::wstring::npos not functional because result of wstring::find gets truncated

TagsNo tags attached.

Activities

mickdermack

2013-09-02 18:35

viewer   ~~0019269

All that is missing now for a full 64-bit server is a 64-bit net.so.
Without that, finding possible bugs on a 64-bit platform is quite hard too.

ccw

2013-09-07 11:31

administrator   ~~0019290

Thanks.
Applied in http://code.google.com/p/mtasa-blue/source/detail?r=5794

Issue History

Date Modified Username Field Change