View Issue Details

IDProjectCategoryView StatusLast Update
0007334Multi Theft Auto : San AndreasServerpublic2014-05-23 01:53
ReporterTjong Assigned To 
PrioritynormalSeverityblockReproducibilitysometimes
Status closedResolutionunable to reproduce 
Summary0007334: triggerEvent in onResourceStart does not work
Description

This bug is a serious problem for me, as I use a variation of the snippet posted below in nearly every resource I create as a predefined useful event, but since a few days this thing is very often not working which leads to the problem that my server hangs itself because players don't get initialized and therefore can't finish the gamemode...

The problem does only occur when I start modes with the mapmanager (e.g. using the admin-panel or export-functions) because a mapmanager start of the code posted below will produce:
[17:48:32] Starting eventtest
[17:48:32] INFO: resource start
[17:48:32] INFO: trigger event: [Ne]#ffa800Tjong
[17:48:32] Gamemode 'EventTest' started.
[17:48:32] start: Resource 'eventtest' started

but if I start it with the console with "start eventtest" it outputs:
[17:48:10] start: Requested by [Ne]#ffa800Tjong([Ne]Tjong)
[17:48:10] Starting eventtest
[17:48:10] INFO: resource start
[17:48:10] INFO: trigger event: [Ne]#ffa800Tjong
[17:48:10] INFO: player init got called
[17:48:10] Gamemode 'EventTest' started.

The bug occured on a 1.3 and also on a 1.3.1 server and of course I used the current version of mapmanager and the other resources.

Steps To Reproduce

addEvent("onPlayerInit");
addEventHandler("onResourceStart", resourceRoot,
function ()
outputDebugString("resource start");
for _, player in pairs(getElementsByType("player")) do
outputDebugString("trigger event: "..getPlayerName(player));
triggerEvent("onPlayerInit", player);
end
end
);
addEventHandler("onPlayerJoin", root,
function ()
outputDebugString("player join: "..getPlayerName(source));
triggerEvent("onPlayerInit", source);
end
);

addEventHandler("onPlayerInit", root,
function ()
outputDebugString("player init got called");
end
);

TagsNo tags attached.

Relationships

related to 0006861 resolvedlil_Toady Teams members aren't sent to clients if set in onResourceStart 

Activities

sbx320

2013-05-31 01:02

administrator   ~~0018616

I'm unable to reproduce this issue. Is it still present in the current version for you?

Issue History

Date Modified Username Field Change