View Issue Details

IDProjectCategoryView StatusLast Update
0006999New issuesClientpublic2015-05-28 19:45
Reporterarezu Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Summary0006999: onClientKey should support characters like åäö½!"#¤%&/()=@{£$]} etc.
Description

onClientKey should support characters like åäöèÈ !"#¤%&/@% etc.
It is possible to detect when player pressed keys like '%&/'; in which you check when player holds shift and pressed numbers, but its different depending on which language your keyboard is made for so it works only if everyone has the same keyboard layout, and there is currently no way to get keys like ?ýr?p$åäöéëáÀ.

When i press 'ö' on my keyboard, it says I pressed ';'.

Additional Information

I and others wants this feature because we want to make custom GUI.

TagsNo tags attached.

Relationships

child of 0006375 closed Unicode issues 

Activities

arezu

2012-04-09 02:10

viewer   ~~0016443

I just found undocumented event onClientCharacter which is more accurate, but it doesn't still support åäö¤

arezu

2012-04-09 05:16

viewer   ~~0016444

There would be a way to do it if there were a function like guiSetFocus (create a gui-edit and set focus on it, set alpha to 0 and onClientGUIChanged to get the character typed)

Issue History

Date Modified Username Field Change