View Issue Details

IDProjectCategoryView StatusLast Update
0006676New issuesClientpublic2011-11-30 19:10
ReporterLooooP Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0006676: When MTA is minimized it still playing the game's and MTA's sounds
Description

When you minimize MTA it still playing the game's and MTA's sounds unlike Single Player that stop playing all sounds.

Additional Information

OS: Windows 7 Home Premium SP1 x86
GTA San Andreas 1.0 US
MTA:SA 1.1.1 r3453
Sound Drivers up-to-date

This may happens because when minimized MTA doesn't freeze the game as Single Player do. Maybe setting Radio, FX, MTA and Voice sound to 0 while minimized and restoring they back while maximized should solve the problem :)

TagsNo tags attached.

Relationships

duplicate of 0005950 resolvedccw Multi Theft Auto : San Andreas Turn off sounds when MTASA is minimized 

Activities

lil_Toady

2011-11-22 22:06

administrator   ~~0015263

Single player pauses the game, unlike mta.

JR10

2011-11-22 22:11

viewer   ~~0015264

Last edited: 2011-11-22 22:13

Pausing the game is impossible, it's multiplayer.
How about muting the sound?
Not that important though.

arranTuna

2011-11-23 10:59

manager   ~~0015265

I don't agree to this. If you don't like hearing stuff when minimized change your volume settings before you minimize.

LooooP

2011-11-23 16:46

reporter   ~~0015267

How annoying have to set manually all sounds to 0 every time I want minimize the game and then restore manually they all when I maximize the game...

May add an option to choose if you want the sounds get muted if the game is minimized. In my opinion it's really annoying have to hear the game sounds even if I'm doing another thing...

BinSlayer

2011-11-23 17:03

viewer   ~~0015269

addEventHandler('onClientMinimize' , getRootElement(),
function()
for i, sound in ipairs(getElementsByType('sound')) do
setSoundVolume(sound, 0)
end
end
)

^basic example

It's also possible to save each sound's volume with getSoundVolume() for restoring :)

In my opinion, there's no need for MTA:SA to change the way it works when server administrators can script their way around it.

LooooP

2011-11-23 17:22

reporter   ~~0015270

Last edited: 2011-11-23 17:23

^ That doesn't work for world sounds (only for sounds created with MTA functions).

arranTuna

2011-11-23 18:05

manager   ~~0015271

http://wiki.multitheftauto.com/wiki/SetAmbientSoundEnabled

LooooP

2011-11-24 01:21

reporter   ~~0015272

Last edited: 2011-11-24 01:30

^ Suppose we use this script:
addEventHandler('onClientMinimize', getRootElement(),
function()
setAmbientSoundEnabled("gunfire", false)
setAmbientSoundEnabled("general", false)
for i,s in ipairs(getElementsByType("sound")) do
setSoundVolume(s, 0)
end
end
)

addEventHandler('onClientRestore', getRootElement(),
function()
setAmbientSoundEnabled("gunfire", true)
setAmbientSoundEnabled("general", true)
for i,s in ipairs(getElementsByType("sound")) do
setSoundVolume(s, 1)
end
end
)

##################################

What about vehicle engine, ped, vehicle horn, voice and many others sounds? Dude, if I minimize a program is because I don't want see and don't want hear anything from it, MTA is the only program that doesn't respect it.

Issue History

Date Modified Username Field Change