View Issue Details

IDProjectCategoryView StatusLast Update
0006477Multi Theft Auto : San AndreasServerpublic2014-05-23 01:01
ReporterBober Assigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionunable to reproduce 
Summary0006477: Mta dont support special characters in httpWrite
Description

site is decode in utf-8

TagsNo tags attached.

Relationships

child of 0006375 closed New issues Unicode issues 

Activities

MX_Master

2011-09-04 07:45

viewer   ~~0014667

please put "steps to reproduce" code on pastebin.com

Bober

2011-09-04 11:26

viewer   ~~0014670

Last edited: 2011-09-04 11:27

code:
http://pastebin.com/xGCXTEuw
result:
http://img5.imageshack.us/img5/3295/specialchapters.jpg

MX_Master

2011-09-04 13:02

viewer   ~~0014676

you must put a special line into HTML page header with encoding name

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

please, show page source

Bober

2011-09-04 15:05

viewer   ~~0014683

Last edited: 2011-09-04 15:08

i send only bug code
full code:
http://pastebin.com/gdU0HAb6

//edit
charset="UTF-8" too dont show

MX_Master

2011-09-04 15:17

viewer   ~~0014685

your

<meta http-equiv="Content-Type" content="text/html" charset="utf-8_bin" />

syntax is incorrect. Use

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

instead.

Bober

2011-09-04 15:19

viewer   ~~0014686

too dont show

MX_Master

2011-09-04 15:53

viewer   ~~0014687

Last edited: 2011-09-04 15:54

Save your HTML file in UTF-8 without BOM encoding. And also check if syntax

<* httpWrite( "yourUnicodeText" ) *>

working as

<* = "yourUnicodeText" *>

and

yourUnicodeText

sbx320

2014-05-23 01:01

administrator   ~~0020927

Unable to reproduce when <meta charset="utf-8"> is set.

Issue History

Date Modified Username Field Change