View Issue Details

IDProjectCategoryView StatusLast Update
0006200New issuesClientpublic2016-12-27 17:05
ReporterAlexxxxx Assigned To 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionunable to reproduce 
OSWindows 
Summary0006200: Crash when aiming with sniper rifle
Description

Sometimes when I'm aiming with sniper all the time, MTA crashes.
My friend also haves this problem.

Steps To Reproduce

Aim a lot with sniper rifle.

TagsNo tags attached.

Activities

x86

2011-06-23 22:49

administrator   ~~0013774

Attach a .dmp file.

Alexxxxx

2011-06-24 16:46

viewer   ~~0013779

I get permission denied when I try to upload it.

Alexxxxx

2011-07-08 14:50

viewer   ~~0013921

Version = 1.0.5-release-2560.0.000
Time = Fri Jul 08 14:50:38 2011
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x000D3FBC

EAX=4615DA00 EBX=00000001 ECX=00000000 EDX=16F80CD0 ESI=13ED2FB8
EDI=00000000 EBP=000000E0 ESP=0028FBA8 EIP=004D3FBC FLG=00010206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Maccer

2011-07-08 20:00

viewer   ~~0013926

No, try again, upload the .dmp file. To something like mediafire and perhaps post a link?

CWanted

2012-05-29 20:51

updater   ~~0016720

Last edited: 2012-05-30 16:00

Shooting with sniper rifle for a long period of time makes SA executable crash (I have noticed that game crashes when performing shooting sound).
Sometimes game crashes when just aiming.
Dumps (press dat big black button on the left) http://rghost.ru/38361595

http://rghost.ru/38375362 this time game crashed after just entering aiming

Rename this issue to 'Crashing when aiming with sniper rifle' or something like that so it will have proper title.

CWanted

2012-06-01 16:41

updater   ~~0016741

More crashes http://rghost.ru/38416900

CWanted

2012-06-25 17:47

updater   ~~0016892

Recent crash http://rghost.ru/38866559

CWanted

2012-06-30 14:58

updater   ~~0016929

Last edited: 2012-10-07 18:52

http://rghost.ru/38955382

CWanted

2012-10-07 18:54

updater   ~~0017697

Looking with sniper rifle at explosion = crash
http://rghost.ru/40797511
http://bugs.mtasa.com/view.php?id=7256

Dutchman101

2014-06-14 15:31

updater   ~~0021022

Last edited: 2014-06-14 15:32

View 2 revisions

It just happened again for me,same crash still,and shooting with sniper

Version = 1.3.5-release-6531.0.000
Time = Sat Jun 14 15:28:31 2014
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\proxy_sa.exe
Code = 0xC0000005
Offset = 0x000D3FBC

EAX=FE95D7E0 EBX=00000000 ECX=00000000 EDX=1D6E69F4 ESI=3C7FFAC8
EDI=00000000 EBP=000000E0 ESP=0028FBA8 EIP=004D3FBC FLG=00010282
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

i attached the crashdump on this issue

Dutchman101

2014-06-19 22:49

updater   ~~0021065

Last edited: 2014-06-19 22:50

View 2 revisions

For referention in future, (if any dev wants to look into it) this crash happens
on CAnimManager::AddAnimBlockRef when it is called with an invalid anim block id.

to fix that one we'd need to find out where that invalid id comes from
since that id isn't only used for AddAnimBlockRef..

it's an old existing crash and it might be a goal to fix on long-term but it seems to be hard because of this.

CWanted

2016-07-22 20:20

updater   ~~0024972

Can you please retest this? Take a sniper and keep shooting for a minute or two. Bet its related to 8272.

qaisjp

2016-07-22 20:33

administrator   ~~0024973

You'll need to grab a new nightly build tomorrow to test it, by the way

arranTuna

2016-12-27 17:05

manager   ~~0025571

Unable to reproduce spamming sniper rifle aim, tried crouched, moving, etc. Should have found a reproduce-able way to get the crash because I can't find it.

Issue History

Date Modified Username Field Change