View Issue Details

IDProjectCategoryView StatusLast Update
0006065Multi Theft Auto : San AndreasClientpublic2011-07-09 00:23
ReporterKernell Assigned Toccw  
Status resolvedResolutionfixed 
Platformx64OSWindows 7OS Version7600
Target Version1.1Fixed in Version1.1 
Summary0006065: 1.1 FPS issues

Parent of all 1.1 FPS issues

Additional Information

Please add any comment you have to the relevant child issue.

TagsNo tags attached.


parent of 0006060 resolvedccw Multi Theft Auto : San Andreas 1.1 FPS issue 1: dxscoreboard reduces FPS (much more than in 1.0.5) 
parent of 0006144 resolvedccw Multi Theft Auto : San Andreas 1.1 FPS issue 2: In the Map Editor FPS down to 2 in the color picker. 
parent of 0006146 resolvedccw Multi Theft Auto : San Andreas 1.1 FPS issue 3: FPS drops on shoot from "Hunter" 
parent of 0006147 resolvedccw Multi Theft Auto : San Andreas 1.1 FPS issue 4: FPS drop after restarting a resource. 
parent of 0006148 resolvedccw Multi Theft Auto : San Andreas 1.1 FPS issue 5: Periods of FPS drops for no apparent reason 
has duplicate 0006091 closed New issues Extremely bad framerate in 1.1 



2011-05-04 13:34

administrator   ~~0013295



2011-05-04 13:56

manager   ~~0013296

Does this happen always? Does it happen when editing the same map? Have you considered that it might be related to your computer slowing down? Do anyone suffer from this problem as well?


2011-05-04 14:48

reporter   ~~0013297


Does this happen always?
Almost always

Have you considered that it might be related to your computer slowing down?

CPU: Intel Core 2 Duo E7200
GPU: NVIDIA GeForce 250 GTS 1024mb
RAM: 4x1024mb 800mhz

Do anyone suffer from this problem as well?

Most of the players complain about the low FPS


2011-05-04 16:12

viewer   ~~0013298

Same Problem here

CPU:AMD Phenom X4 955
GPU:AMD 6870 1024mb
RAM:2x2048mb @1333 mhz

All drivers Up to Date


2011-05-04 17:05

viewer   ~~0013302

Last edited: 2011-05-04 17:07

open local.conf (placed near mtaserver.conf) file and change





2011-05-04 18:50

reporter   ~~0013305

So there is currently


2011-05-04 20:01

manager   ~~0013307

Not just the hardware. Do you have an antivirus running? Have you checked that it's not another process slowing it down?


2011-05-04 20:36

viewer   ~~0013310

yep, antivirus (firewall) is the second possible reason


2011-05-04 21:15

manager   ~~0013311

He is using 1.1 unstable (or at least thats what he put as product build) and there is well known low FPS issues in 1.1 unstable.


2011-05-04 22:29

viewer   ~~0013316

i'm also using 1.1-unstable but my FPS is 50-70 if limit is set to 70 and 70-100 if limit is 100

may be it's map with many elements?


2011-05-09 22:45

reporter   ~~0013348

I'm not stupid!

Maybe the problem only on Windows 7?

The number of objects on the map is not affected.


2011-05-09 22:52

viewer   ~~0013349

FPS drop is confirmed on WinXP too. But this drop isn't constant, it's appears only 'sometimes'.


2011-05-10 10:54

viewer   ~~0013352

Last edited: 2011-05-10 10:57

I made some simple tests.

Server options:

  • 1.1-unstable-2625
  • fpslimit = 100
  • other options - defaults.

OS options:

  • WinXP SP3
  • all unneeded programs OFF
  • firewall/antivirus OFF
  • only Fraps is working

HOST GAME options:

  • 2 player slots
  • admin resource to start/stop resources
  • play resource for the first spawn

TEST 1 - just host local server and enter it (HOST GAME), stop play, create vehicle with admin and drive through all map. Fraps always show me 98-101 FPS.

TEST 2 - while on the server, start map with 1500 vehicles for all map and drive through all map again. Fraps show me 85-101 FPS.

TEST 3 - while on the server, start freeroam resource. Now are working admin, vehicles map and freeroam. Drive through all map. Fraps show me 68-101 FPS.

I mades this tests twice and first time after starting freeroam FPS always was 50-60 until I stop it. Another time after freeroam start FPS was 98-101 and drops only while city trip by vehicle.


  • many vehicles drops FPS a little
  • even simple resources as freeroam can drop client FPS so slow
  • admin resource works without FPS drops

Not optimized resources can drop client FPS a little more than 68. Just try to start all standart resources (play, scoreboard, ...) and you will see a serious FPS drop.

Also problem may be in the GUI. Resource which using many GUI elements can drop client FPS slower than resources not using GUI at all.


2011-05-10 16:39

manager   ~~0013358

The best way to reproduce this for me is by opening dxscoreboard (60 FPS drops to 30 FPS) and its not any of the DX because I've tried it with all DX drawing commented out.


2011-05-10 17:11

viewer   ~~0013359

my own DX library even with 100 drawing elements not drops FPS at all, because it not using other scripting functions except dxDraw.... Many simple calculations not drops FPS.

i think some scripting functions drops FPS while their often using


2011-05-10 20:54

viewer   ~~0013360

I think there's too much calculating/string-splitting left to do in the drawing of dxscoreboard on onClientRender event, because when I'm alone in the server, it doesn't really cause any lag, but starting from x-number of people it really starts to affect FPS.


2011-05-10 21:15

viewer   ~~0013361

Last edited: 2011-05-10 21:40

it's not a problem of specific resource, because we test it on different resources and they reduces FPS in same manner

if somebody interested in fixing this problem, just make some simple script tests, which may show what kind of functions drops FPS

-- later ..
I'm just viewed dxscoreboard's source.. it uses a lot of functions every frame instead of store this data as vars and update only when it's needed. Some calculations can be made once (when it's needed) but they makes every frame. It's not optimized resource.


2011-05-10 22:18

manager   ~~0013362

dxscoreboard does cache some of its information (some part of it doesn't update per frame but time basis)

The point here is that opening dxscoreboard had zero FPS drop in 1.0.5 yet for me has a 30 FPS drop in 1.1


2011-05-10 22:37

viewer   ~~0013363

dxscoreboard has affected my FPS for quite some time already from 45 FPS (limit) to 33 when open. That's from 1.0.4 (at least).


2011-05-10 22:59

administrator   ~~0013364

dxscoreboard does affect my client in 1.0.5 too


2011-05-11 10:39

viewer   ~~0013365

it's not a problem of specific resource .. (quote from mine post)

On resource start FPS drops a little, and no matter what resource it was. I know only one thing - without started resources FPS is constant.

Some days ago i tested my 1.0.5 GM on 1.1 version and saw large FPS drops. But on 1.0.5 FPS was pretty constant.


2011-05-11 14:24

manager   ~~0013366

Ok forget the dxscoreboard thing, I was wrong.

I can concur with MX_Master about FPS drop after restarting a resource. I had steady 60 FPS, restarted a resource and it became stuck on 15 FPS until I reconnected.

I would check if this was caused by the resource in performance browser but can't due to #6082


2011-05-11 16:16

viewer   ~~0013367

I found possible fix for the map editor low FPS behavior (: just another .conf file must be edited - editor.conf.


must be changed to




2011-05-12 14:02

reporter   ~~0013374

Last edited: 2011-05-12 14:03

I have run a normal server (1.1) with resource 'play' (standard mtaserver.conf, changing only <fpslimit> to 100).
The problem also exists.

FPS drops frequently.


2011-05-22 14:09

viewer   ~~0013450

I have this Problem too (Intel Q950 and GTS 250) and in complex guis my fps are 4-7. And normaly i have 60fps and when i drive by car then i have 20fps.


2011-05-25 04:24

viewer   ~~0013477

I also have this problema. This is since the new server browser. Maybe because it starts to check the servers or something like that. I have more fps disabling the refresh of the server browser but it still having fps drops.


2011-05-25 05:54

viewer   ~~0013478

Sometimes FPS drops to 5-10 while flying on the heli or plane, but this FPS drop is short (3-10 sec.)


2011-05-28 04:05

updater   ~~0013494

Issue automatically marked as fixed by mantisbot ( Fixed in )


2011-05-28 20:04

viewer   ~~0013500

It's better but not totaly fixed. Sometimes the FPS drops around 10 FPS for 1-3 seconds (No Resource loaded).


2011-05-28 21:25

viewer   ~~0013501

DX it's not the source of low FPS problem, problem of (onRender) drawing is many calculations before drawing (: and even without any draws, other players and elements i still see big FPS drop while slow walk across game streets

if you just stay still, not moving and not rotate camera - your FPS will be constant


2011-05-28 22:32

administrator   ~~0013502

Please say what exact build you are using.


2011-05-29 09:43

viewer   ~~0013503

2703, 2698 and earlier versions had same drops

i think source of this problem can be in creating/destroing streamed in/out elements, because these drops can be even in the place where no elements in stream distance at all, but only when we enter/exit these free areas


2011-05-29 11:08

administrator   ~~0013505

Please tell me the exact steps to reproduce this issue on 2703


2011-05-29 12:06

viewer   ~~0013506

  • just start server with admin, freeroam and scoreboard
  • ask few friends (2-3) to connect to it
  • enable FPS counter (in fraps for example)
  • just fight, drive or fly with them
  • talk in chat with Unicode messages


2011-05-31 15:09

reporter   ~~0013538

Still relevant.

And FPS drops fired from Hunter.


2011-05-31 18:09

administrator   ~~0013540

FPS from ?
FPS to ?
How long does drop last for?


2011-05-31 20:31

viewer   ~~0013543

For me:

  • Short FPS drops (1-3 sec.) from 100 to 5-10.
  • Long FPS drops (3-10 sec) from 100 to 40-50.

Exact reason is really unknown (: because we haven't tools to monitor client's actions at the moment.


2011-05-31 20:47

reporter   ~~0013544

I have no FPS by more than 60.
FPS drops on shoot from "Hunter" to 25 (sometimes less).


2011-05-31 20:48

reporter   ~~0013545

The problem is not solved


2011-06-02 07:21

administrator   ~~0013552

Kernell, does this still occur:

'In the Map Editor FPS down to 2 in the color picker.'


2011-06-02 08:51

administrator   ~~0013553

Reminder sent to: Kernell

Kernell, does this still occur:

'In the Map Editor FPS down to 2 in the color picker.'


2011-06-02 16:39

manager   ~~0013557

I was testing this with Gamesnert. I was getting large FPS drops when somebody was shooting so he made a custom build with some debug for me as he couldn't get the FPS drop.

When using the custom build I wasn't getting the problem, so you have to install an actual nightly to get the FPS drop perhaps the reason why you can't reproduce it, ccw.


2011-06-03 07:11

administrator   ~~0013565

I've split this issue up as there seems to be a few different things going on, which may, or may not be related.

Please add any comment you have to the relevant child issue.


2011-06-03 15:38

viewer   ~~0013577

very interesting (: we have big FPS drops only on nightly builds

but on Custom Build we have just small drop (less than 25, 100 -> 80)


2011-06-12 12:46

reporter   ~~0013656

Nice job!
So far no problems!


2011-06-15 19:52

viewer   ~~0013682

Last edited: 2011-06-15 19:55

i think this issue can be closed (at least #0006144, #0006148 parts of it). All things is fine now. There are no such FPS drops in custom builds


2011-06-15 19:59

manager   ~~0013684

Last edited: 2011-06-15 22:28

Whatever difference there is between a custom and normal build seems to be the problem of all this.

Edit: I've been using a normal build and just realised that I'm not getting any more FPS drop. Is anyone else still getting FPS drops? (Make sure you're using a new nightly)

Issue History

Date Modified Username Field Change