View Issue Details

IDProjectCategoryView StatusLast Update
0005856Multi Theft Auto : San AndreasClientpublic2018-09-05 17:33
ReporterDzakub Assigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version7
Summary0005856: Chinese letters on title bar
Description

My Windows language is PL, always worked fine.
Sometimes alt+tabbing changes letters to different.

TagsNo tags attached.

Relationships

child of 0006375 closed New issues Unicode issues 

Activities

LooooP

2011-01-24 11:52

reporter   ~~0012719

I can confirm

truelife

2011-01-25 00:06

viewer   ~~0012728

I too can confirm

Talidan

2011-01-25 00:17

administrator   ~~0012731

Potential fix in r2361, Please retest in a newer build

xUltimate

2011-01-25 03:59

viewer   ~~0012736

I can confirm that it is not a fix, as I am friends with truelife and I had him update to the newest build but it still was in the bullshit china crap.

Talidan

2011-01-25 06:47

administrator   ~~0012740

Last edited: 2011-01-25 06:51

Do you play in fullscreen mode? Need some steps to reproduce

Dzakub

2011-01-25 14:39

viewer   ~~0012745

Not fullscreen 800x600 resolution (or 1024x768). Seems working only on my laptop, on PC title bar is normal.

Talidan

2011-02-14 03:46

administrator   ~~0012924

I've made a experimental fix for this bug, if someone could test it with this build:

http://dl.dropbox.com/u/19116546/mtasa-1.1-unstable-2417_windowfix.rar

Talidan

2011-02-16 15:41

administrator   ~~0012951

Updated version, this should fix it:

http://dl.dropbox.com/u/19116546/mtasa-1.1-unstable-2417_windowfix4.rar

ccw

2011-02-17 01:30

administrator   ~~0012953

Please check the compatibility settings:
Right click on 'Multi Theft Auto.exe', select 'Properties' and then click the 'Compatibility' tab. Anything set there?

Mr.Hankey

2011-02-17 13:52

reporter   ~~0012954

Nothing set there for me.

Talidan

2011-02-17 19:40

administrator   ~~0012958

Here's a new version, which i believe should fix it:
http://dl.dropbox.com/u/19116546/mtasa-1.1-unstable-2417_windowfix5.rar

It changes the text to be monospaced.

Tjong

2011-02-17 20:22

viewer   ~~0012960

not fixed for me

Mr.Hankey

2011-02-17 22:01

reporter   ~~0012961

same here

it changed the font/appearance in the task bar though: http://i56.tinypic.com/2afa8tg.jpg :/

jhxp

2011-05-09 09:55

administrator   ~~0013341

Seems to be still an issue.

Windows 7 x64 SP1 (Polish) - Windows Classic theme.

Talidan

2011-05-09 09:59

administrator   ~~0013342

We found the origin of the issue eventually. It's a bug in Windows when using the Classic theme on a non-english OS.

Not much we can do without asking MS to fix it.

x86

2011-08-11 23:51

administrator   ~~0014235

How 2 reproduce ?

qaisjp

2011-08-12 12:15

administrator   ~~0014236

I'm using an english laptop bought from england running windows 7 with language English (UNited kingdom), and i play windowed. The "Disable Aero" stopped working for me ( Meh suspect chrome has something to do with this) and when minimising i see the pleasant chinese letters (or w/e)

x86

2011-08-12 14:08

administrator   ~~0014237

IsWindowUnicode returns false for MTA.

Picard

2011-08-12 15:43

updater   ~~0014238

Issue automatically marked as fixed by mantisbot ( Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=2988 )

x86

2011-08-12 18:42

administrator   ~~0014240

Please retest with newest 1.1 nightly!

Maccer

2011-08-25 15:42

viewer   ~~0014443

This is fixed, why is this still open?

Dzakub

2011-08-29 10:51

viewer   ~~0014521

Last edited: 2011-08-29 10:52

No, it is not fixed. Title bar is still messed up on 1.1 Nightly.
Specs:
Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7600)(7600.win7_gdr.110622-1503)
Language: Polish (Regional Setting: Polish)
System Manufacturer: TOSHIBA
System Model: Satellite A200
BIOS: Ver 1.00PARTTBL
Processor: Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz (2 CPUs), 1.8GHz
Memory: 1536MB RAM

Maccer

2011-11-20 05:24

viewer   ~~0015259

As an update, I could not reproduce on the RC nightlies and stables.

BUT, when I compile my own MTA:SA Custom, I get this bug. And both my language and regional settings are English.

I think there's some weird shit pertaining to MSVC.

Jockie

2011-12-18 23:19

viewer   ~~0015405

Comfirmed at v1.2-release-3550

Windows 7 Ultimate 32-bit
Language: Dutch

  • Disable Aero
  • Full Minimize enabled
  • Alt-tab and look at the short showing title bar.
    (This isn't any problem though.)

When using Windowed the title bar is called like it should be.

Inspirator

2015-03-27 14:55

viewer   ~~0023129

Last edited: 2015-03-27 14:58

Can confirm this. Win 7 Ultimate x64, English, US keyboard format, Classic theme. http://qs.lc/ky2xt

Woovie

2015-03-27 14:57

manager   ~~0023130

What version of MTA are you using? This is a really old bug.

Inspirator

2015-03-27 14:58

viewer   ~~0023131

Multi Theft Auto v1.4.1-release-7093

arisu

2015-03-28 10:54

viewer   ~~0023133

Can confirm this on Wine 1.7.39. http://i.imgur.com/bOkocTK.png

qaisjp

2018-09-05 06:59

administrator   ~~0026938

generally fixed, except for wine. i encourage anyone who wants this to be fixed in wine to repost on github

Issue History

Date Modified Username Field Change