View Issue Details

IDProjectCategoryView StatusLast Update
0005015New Feature Requests[All Projects] Generalpublic2018-09-03 17:52
Reporter[PS]DazzaJay[AU]Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionsuspended 
Summary0005015: [Request] Compress the sending of resources to the client.
Description

i think it would be a good idea to Compress the sending of Client side files to the client, As Custom DFF and TXD's can be quite large. (look at our initial D Server for example, 14 custom cars + Akina = 80MB)

Where as DFF's and most TXD's will compress quite well, on average to 48% of their original size.

Im guessing the best way would be some kind of On-The-Fly compression, like Z-Mode in FileZilla servers.

TagsNo tags attached.

Relationships

related to 0006816 new New Feature Requests Package Compression 
has duplicate 0004722 closed New issues [REQUEST] Compressed Resource Downloading 
has duplicate 0006915 closed New issues Make resources download in one .zip file.. 
has duplicate 0007665 new New Feature Requests Send Resources in a compressed file 
has duplicate 0007844 new New Feature Requests [Request] zip \ unzip functions 
has duplicate 0005191 closed New issues unpackZIP or unpackArchive clientside 
related to 0005951 closed New issues server zipping resources before sending 

Activities

Maccer

2010-03-17 15:26

viewer   ~~0011181

I proposed using 7z once. Extracting does take some time/cpu usage though.

XX3

2010-03-17 15:28

viewer   ~~0011182

Yeah, this happened to me also, as it made a loong time to download these maps and custom cars.

MX_Master

2010-10-30 18:07

viewer   ~~0012085

great suggestion, will be great economy of server traffic and new player's nerves

eAi

2010-11-07 03:21

administrator   ~~0012124

I'd suggest using standard HTTP compression to do this so that external servers can be supported.

Curl probably already does this automatically for us with external servers, so 'all' we'd need to do is make EHS support it.

http://en.wikipedia.org/wiki/HTTP_compression

Feche

2012-03-01 17:29

viewer   ~~0016192

I support this, it would also make download faster on resources that have lot's of files.

diegofkda

2012-03-02 19:38

viewer   ~~0016202

Last edited: 2012-03-02 19:38

My server has actually 16 cars + akina and its size is 39 mb, you should take care about what car you are uploading too and make its TXD at least smaller.

LeetWoovie

2012-04-15 00:06

viewer   ~~0016459

This isn't about file size of DFF or TXD. It's about how long it takes to send 800 lua files versus sending 1 lua cache and uncompressing it. Sending 1 100mb file versus 100 1mb files is a lot faster.

PhatLooser

2012-04-20 12:33

reporter   ~~0016502

Last edited: 2012-04-20 12:35

Currently it is like that, the server accepts .zip as resources. Why not add that client side?
Put dem http-client-files in zips. One zip each resource. This way the server doesn't have to compress dat shice every connect.

Since most servers don't have more then 10 resources running, that shouldn't be an issue to download that.

arranTuna

2012-04-21 17:51

manager   ~~0016514

LeetWoovie if you're having problems with slow download because of all the small files you need to use external web server which is about 4 times faster to download than using the default.

Jaysds1

2012-05-14 15:20

viewer   ~~0016646

Is it possible to add a password to the compressed resources?
There could be a mtaserver line like: <compresspassword>password</compresspassword>

x86

2012-05-16 13:32

administrator   ~~0016653

Why Jaysds1 ?

(SAUR)Dwayne

2012-05-18 03:19

viewer   ~~0016670

I actually think Jaysds1 is on to something.
By using a password, client files can be locked to a certain server, and nosy people wouldn't be able to acces the client files without knowing the compress password.
The server basicly sends the compress password to the client on connect, the client system decompresses the files into a temporary location, to use.

Feche

2012-09-02 21:23

viewer   ~~0017434

Is this going anywhere... ?

ccw

2012-09-02 21:30

administrator   ~~0017435

As you can use an external http server to handle compression, this issue is not a priority

CWanted

2012-09-14 16:18

updater   ~~0017569

http://bugs.mtasa.com/view.php?id=5191
http://bugs.mtasa.com/view.php?id=5951

Issue History

Date Modified Username Field Change