View Issue Details

IDProjectCategoryView StatusLast Update
0004990Multi Theft Auto : San AndreasGeneralpublic2018-09-05 17:46
Reporter50pAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version1.0 
Target VersionFixed in Version 
Summary0004990: dxDrawLine3D - rendering issues
Description

There are a few rendering issues with 3D lines. I added a screenshot showing all of them.

1*. HUD - the lines are drawn on top of HUD. I thought it's caused by "postGUI" parameter being set to "true" but that's not the case because it's for CEGUI elements only. I think it should be drawn under the HUD because it's "3D" or let the "postGUI" parameter decide.

2*. Fire - same thing. Lines are drawn on top of fire coming from Jetpack.

  1. Radar - same as above but they are rendered twice. This is tricky one... There is some offset of the drawn lines. The offset is variable, it changes as the angle of the camera and line itself.

  2. Radar bounding box - this is weird but the lines aren't visible in corners of the radar bounding box.

    • the line doesn't have to be rendered between camera and the object (HUD or fire) position (screen Z-index)
TagsNo tags attached.

Relationships

related to 0003406 closed Streamed in marker elements cause 3D DX lines to dissappear 

Activities

PhatLooser

2010-05-31 18:44

reporter   ~~0011527

Sometimes the 3D line isn't drawn at all.
I will add a video later.

eAi

2010-06-01 00:46

administrator   ~~0011530

This would probably be better as separate linked issues.

Vincent

2012-03-22 11:41

viewer   ~~0016351

http://code.google.com/p/mtasa-blue/source/detail?r=3935
does this mean it's now fixed?

Dragon

2012-03-24 11:19

reporter   ~~0016364

the radar thing seems like someone already tried to make lines not draw on top of the mini map but chose the wrong area part to not draw them on

arranTuna

2013-09-16 20:24

manager   ~~0019341

  1. Is definitely fixed when using onClientHUDRender probably 3 and 4 too which only leaves 2 which already has it's own report: #7167

socialz

2013-09-28 22:32

viewer   ~~0019406

Adding, that when drawing a line from position A to position B and your camera is not nearby the other end of the line, it will cause the line to go around and around in a circle shape.

If unsure, I'll post a video when possible.

einheit-101

2016-10-02 18:27

reporter   ~~0025269

Is it intended that dxDrawLine3D is visible through objects aswell??? Thats not really 3D my friends^^

ccw

2016-10-03 00:15

administrator   ~~0025278

Steps to reproduce please

einheit-101

2016-10-03 14:35

reporter   ~~0025283

Last edited: 2016-10-03 14:36

View 2 revisions

Uhmm:
dxDrawLine3D(0, 0, 5, 5, 0, 5, tocolor(0,0,0,255), 2.5)

3D Line on my ship visible through the player:
http://imgur.com/zdl4GlW

3D line of my little basic example in map center visible through Tank and player:
http://imgur.com/2ThAxYu

It does NOT matter if you use onClientRender/PreRender/HUDRender, the outcome is the same.

ccw

2016-10-03 19:30

administrator   ~~0025287

Do you have any active shaders?
Does the problem occur with AA on/off?

einheit-101

2016-10-04 00:35

reporter   ~~0025292

Yup, Shader_water_refract causes this... Looks like it has problems taking these DX lines into its Render Target.

Issue History

Date Modified Username Field Change