View Issue Details

IDProjectCategoryView StatusLast Update
0004350Source patchesMulti Theft Auto : San Andreaspublic2009-06-25 00:08
Reporterlucasc190 Assigned To 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionno change required 
Summary0004350: No Splash Screens Patch (Patch For Issue #0004347)
Description

This patch removes all of GTA's splash screens.

TagsNo tags attached.

Activities

Talidan

2009-05-23 04:29

administrator   ~~0009337

Ideally they would be made skippable - not removed entirely.

lucasc190

2009-05-23 05:01

developer   ~~0009338

What about a setting in the options to remove them?

lucasc190

2009-05-23 08:35

developer   ~~0009339

Last edited: 2009-05-23 10:49

What about a single skippable splash video for MTA that contains NVIDIA's logo on it?

EDIT:
I know how to do this.
I can get it to play any MPG or WMV from anywhere including the MTA data folder. (Skippable)

scarface1994

2009-05-23 09:50

viewer   ~~0009340

Skippable would be the best. At least for now.

lucasc190

2009-05-23 14:43

developer   ~~0009345

I made a patch to make MTA just have a skippable intro movie that reads from "intro.wmv" in the MTA data folder: http://lucasstuff.com/external/mta/MTAIntroMoviePatch.patch

For example intro.wmv could be something like: http://lucasstuff.com/external/mta/intro.zip

Talidan

2009-05-23 16:57

administrator   ~~0009348

Last edited: 2009-05-23 16:58

I actually like this idea. It retains the nvidia and eax logos so we arent pissing off any companies and looks pretty sleek. I'm just not sure about wmv as a format - obviously ideally we could just fade in the logos (i.e. pictures)? Dunno.

Either way i'm happy for this patch to be applied.

edit: Since we already support mkv and h264 (or was it xvid?) it might be wiser to use that.

x86

2009-05-23 16:58

administrator   ~~0009349

lucasc190, could you remove GTA San Andreas splash screen after the intro? :)

Talidan

2009-05-23 17:14

administrator   ~~0009350

In future we could pop up the MTA menu while GTA is still loading. ChrML mentioned it might be a good idea to start the game whilst on the menu without the user realising. This would mean getting ingame would be a lot faster since it would begin to load asap.

Arc

2009-06-25 00:08

administrator   ~~0009729

Fixed with custom code

Issue History

Date Modified Username Field Change