View Issue Details

IDProjectCategoryView StatusLast Update
0004289Multi Theft Auto : San AndreasServerpublic2009-05-20 15:30
ReporterIJsAssigned ToTalidan 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004289: Implement "fun-bugs" server setting that can be enabled
Description

Following a discussion with several people on Multi Theft Auto's policy of disabling original glitches (that shipped with Grand Theft Auto), I've opened this report.

The issue is about whether or not to disable these "fun bugs" that come with the game, but are unfair (from our point of view) for players. The unfair bit comes from the fact that these glitches are hidden and unwanted bugs in the game that require a certain skill to use.

However, the skill to use these bugs and the difficulty of learning them actually provides a challenge for a number of people, notabily those in certain clans or groups. Therefore, completely disabling them could also be considered unfair.

Proposed suggestions for the issue:

  • No disabling of any fun bugs and use scripts to counter-effect them
    -> not recommended: I believe that the bugs should be disabled by default
  • Disable any fun bugs by default and emulate them by scripts
    -> unsure: script emulation may prove to be difficult and inaccurate
  • Disable any fun bugs by default but provide a server variable to enable them
    -> discuss

The variable would enable a series of "unfair" bugs that we have disabled (or may disable in the future), so that the people who use these can still do so without any inaccurate emulation or whatsoever. This sounds like a reasonable idea.

List of "fun bugs" that have been disabled by us:

  • "Running bug": fast walking whilst aiming certain weapons (M4, deagle, etc.)

Relevant revisions: r417, r355, r353

List of "fun bugs" that have not yet been disabled by us:

Please feel free to comment and add any bugs to the list.

TagsNo tags attached.

Activities

robhol

2009-05-10 20:08

reporter   ~~0009159

In my opinion, unless they are disabled permanently, per-server variables are definitely the way to go.

The mod should ideally be balanced and fair, which means players shouldn't have to learn to use bugs to "keep up."

Cazomino05

2009-05-10 20:09

reporter   ~~0009160

Personally I vote for Disable by default and add some option to enable them if people want it the server owner can enable it.

But my opinion is that clients should also be told the bugs are present too, Either to warn new clients or to tell people who want to use the bug they can on this server.

ryden

2009-05-10 20:10

manager   ~~0009161

Never go against those that make you popular.

LordAzamath

2009-05-10 20:13

viewer   ~~0009162

Maybe just a function like setWorldSpecialPropertyEnabled() is right now..
IMO, default should be a fix with either bug reintroduced with script or a server var. Wouldn't be happy about enabling the bugs by default.

[NB]Sneaky

2009-05-10 20:21

viewer   ~~0009163

Last edited: 2009-05-10 20:27

May I add 2-shot to the "fun bugs" list. It's when you shoot 2 out of the 4 bullets out of your sawnoff shotgun(or 1 out of 2 depending on skill level), then switch to another weapon and switch back to sawnoff you will have 4 (or 2..) bullets in your clip again. This bassicly allows you to skip the reload animation and shoot really fast.

And another fun-bug is high jumping with bmx/bike. This is when you got a mp5 or tec9 hold ctrl then bunnyhop and quickly press fire after that, it will bunnyhop twice as heigh as normal bunnyhop. It's really harmless but still a bug, it would fit good under "fun-bugs".

"Disable any fun bugs by default but provide a server variable to enable them"

This is the best idea. 80% of GTA:MP clans use these bugs, c-bug, 2shot etc. It's important to still have an option to enable these fun-bugs. Clans play competitivly with cbug, do clanwars on it etc, without cbug you would dissapoint alot of people playing with this bug daily.

Also I think it's a good idea for the people who are against these bugs, like someone said in #mta "we try to make this mod fair for everyone" and this way it will be ;) hope this helped.

Edit: LordAzamath, yes that would be good!

lil_Toady

2009-05-10 20:27

administrator   ~~0009164

they can all be scripted, i'd rather fix all those bugs

Talidan

2009-05-12 00:00

administrator   ~~0009209

Last edited: 2009-05-12 00:07

r353 is also very relevant.

Many of these fixes were also in place before MTA went open-source.

"* "Crouch bug": fast walking for certain weapons after utilizing a keycombo, aim, shoot 1 bullet, press C (crouch), move can currently be disabled through this script"
I'm not sure about this. As far as i know i prevented this glitch, but i may be wrong.

One remaining glitch is (without aiming) Pressing Fire, Press crouch, Press jump/sprint -> repeat. This allows you to fire slow guns quickly e.g. deagle. This was disabled by ChrML while aiming (which accounts for the majority of glitching) but its still possible without aiming.

I would opt for a scripting function to enable them, but they're disabled by default. Something similar to setting the server's fps limit.

In reply to fast reload, I'm hesitant to decide whether that's a funbug or not. In a lot of cases this isnt considered a glitch - its something that's been in all GTAs and something everyone is accustomed to. If we do provide optional funbug, we should be able to specify which glitches to disable. I would not want to enable quick-reload at the expense of all those other bugs.

Something along the lines of (serverside)
setGamePropertyEnabled ( string property, bool enabled ) and not an overall function to disable all of them. This is mainly because i think quick-reloading is very borderline.

On the other hand, quick-reload block methods can only be reproduced in script serverside (due to the nature of weapon functions) - so a hardcoded method to do it via MTA would be welcomed.

[M2S]moe

2009-05-12 00:19

viewer   ~~0009210

"they can all be scripted, i'd rather fix all those bugs"

My personal view on this is, if you're at all interested in getting the SAMP DM community on MTA, having to script these bugs will make sure they stay on SAMP and never look back (I for one will not bother scripting something that is inherent to the game to begin with).

I am also in favor of a function like setWorldSpecialPropertyEnabled, it seems like the best option so far.

Talidan

2009-05-12 13:52

administrator   ~~0009215

As a scripter, and one of the few who worked on preventing these glitches from working in MTA, i can safely say its totally impractical to try and emulate them in script. It'd simply be a total waste of time and they would never work the same.

[NB]Sneaky

2009-05-15 21:24

viewer   ~~0009239

"As a scripter, and one of the few who worked on preventing these glitches from working in MTA, i can safely say its totally impractical to try and emulate them in script. It'd simply be a total waste of time and they would never work the same."

Agreed, and also agreed with moe :p

About the fast reload, yes it's a GTA feature and it's in all GTA games. However many people dont know about it, and it would be unfair against them. Therefore I'd say disabling them by default would be the best option!

Having A setWorldSpecialPropertyEnabled("funbug-here", true/false) would be great for those clans/people who use cbug and fast reload daily.

And what about the bmx/bike bug? I think this should also be disabled by default, like I said it allows you to jump 2/3 times as high as normal and could be unfair maby.

Talidan

2009-05-19 19:51

administrator   ~~0009281

Use setGlitchEnabled

[NB]Sneaky

2009-05-20 12:52

viewer   ~~0009286

Great job! But I have one more suggestion:

SetGlitchEnabledForPlayer( source, string glitchName, bool enable )

Examples:

A server has by default a fun-bug disabled, but they've got a duel arena (where players can fight eachother 1 on 1) and they want players to be able to use bugs there then SetGlitchEnabledForPlayer could be used :)

Or

A server has by default a fun-bug disabled, but they want fun-bugs enabled in Los Santos then they could make a script something like onPlayerEnterArea(los-santos) do SetGlitchEnabledForPlayer.

[M2S]moe

2009-05-20 13:08

viewer   ~~0009287

+1 x)

[NB]Sneaky

2009-05-20 15:26

viewer   ~~0009288

Last edited: 2009-05-20 15:28

setGlitchEnabled does not work with runcode, it will only be enabled for the players who are connected at that time not for players who connect after that (is it suppose to be like this?)

And it does not seem work at OnResourceStart

Edit: http://bugs.mtasa.com/view.php?id=4329

[M2S]moe

2009-05-20 15:28

viewer   ~~0009289

It doesn't work anywhere, or rather it only works for connected players. However if they reconnect, it doesn't work again. Basically:

1) If you're not connected when the function is ran, it will not apply to you.

2) If you are connected when its ran, it will work until you reconnect, and then won't work again, even though all functions are set to "true".

scarface1994

2009-05-20 15:30

viewer   ~~0009290

" Also don't forget it doesn't work for joining players. Its not finished just yet. "

Issue History

Date Modified Username Field Change