View Issue Details

IDProjectCategoryView StatusLast Update
0004265Multi Theft Auto : EditorEDFpublic2010-01-23 00:32
Reportersubenji99Assigned ToTalidan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0004265: Loading gamemode edf definitions in the editor starts that gamemode resource
Description

Pretty much summed up in the summary.
Create/load a map, decide you need to add (for example) a flag for CTF, or spawns for Stealth, so you load the definition and the editor starts that gamemode - which doesn't run on an incomplete map and breaks the editor (how depends on the gamemode, and what code ends up running.
It can sometimes be even worse - not only does the gamemode get started, but the first thing the gamemode does is load a different map.

Additional Information

Did not happen on an earlier revision of the editor, not sure exactly which, but before resources r100 I think.
Problems occur with all 3 current edf definitions.

TagsNo tags attached.

Activities

ryden

2009-05-06 14:48

manager   ~~0009055

Last edited: 2009-05-06 14:48

As expected, except that it only starts the resource files, not the scripts.
http://development.mtasa.com/index.php?title=StartResource

subenji99

2009-05-06 15:11

viewer   ~~0009057

Last edited: 2009-05-06 15:12

Did you actually even attempt to test this or just fob me off?
I LOVE trying to make a Stealth map and as soon as I click "Save" on the definitions panel, it fades the screen, loads a map, moves the camera and shows Stealth's "Spawn Selection" panel.
I'd say it's running scripts.

Talidan

2009-05-06 15:14

administrator   ~~0009059

Please don't be rude. Unfortunately we do get idiots posting here so we need ensure people know what they're talking about

Talidan

2009-05-06 15:15

administrator   ~~0009060

Last edited: 2009-05-06 15:17

This is due to the new mapmanager changes. Its interfering with the Editor. Need to find a good way to get around this. If you revert to an old version of mapmanager (r104) it should work.

subenji99

2009-05-06 15:20

viewer   ~~0009061

I apologise, but I thought I made my submission clear enough that it was running scripts whether intentionial or not.

Issue History

Date Modified Username Field Change