View Issue Details

IDProjectCategoryView StatusLast Update
0004221Multi Theft Auto : San AndreasClientpublic2009-04-27 09:41
ReportertrjackAssigned Toryden 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004221: Server crash when shooting a clientside vehicle with HS rocket
Description

Run a server.

Start runcode.
Start freeroam or broph.

Press F8 on the MTA MainMenu.
Type "window" and press enter.
(Otherwise it will crash and its harder to quit MTA)

Enter the server in MTA.

Type /crun createVehicle(400,0,0,4)
Type /crun setElementPosition(getLocalPlayer(),10,0,3)
Type /run giveWeapon(getRootElement(),36,5,true)

Now shoot the vehicle aiming with the heat seeking rocket launcher.
AIM WHEN the circle is red and click.

MTA should crash due to it sending the explosion to the server maybe?

Additional Information

This only happens to clientside vehicles.

TagsNo tags attached.

Activities

mekorea

2009-04-25 22:14

developer   ~~0008926

Last edited: 2009-04-25 22:18

= Server crash when shooting client-side vehicles with heatseek while target is locked.

trjack

2009-04-25 22:15

viewer   ~~0008927

EDIT: It was the server that crashed

trjack

2009-04-27 08:45

viewer   ~~0008941

Last edited: 2009-04-27 08:46

I got the server dump file.

EDIT: Cant upload it!

Access Denied!

Issue History

Date Modified Username Field Change