View Issue Details

IDProjectCategoryView StatusLast Update
0003406Multi Theft Auto : San AndreasGeneralpublic2018-09-05 17:33
ReporterTalidanAssigned To 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0003406: Streamed in marker elements cause 3D DX lines to dissappear
Description

Marker elements seem to cause any nearby 3D lines created using dxDrawLine3D to dissappear. 2D dx draws are unaffected however.

TagsNo tags attached.

Relationships

related to 0003705 resolvedlil_Toady dxDrawLine3D no longer works 
related to 0004990 closed dxDrawLine3D - rendering issues 
child of 0002949 closed Map editor issues 

Activities

Talidan

2008-09-22 18:19

administrator   ~~0008026

Not needed for dp3 i guess, though its a general bug that affects any gamemodes that use 3D lines.

Ryder!

2009-08-05 01:38

viewer   ~~0010129

it also occur when the player is carrying a weapon, the lines disappears.

R3mp

2011-06-09 20:17

viewer   ~~0013624

I found that drawing effects on the screen (or viewing ones from gta) stops the lines from disappearing when you have a weapon equipped (this is why they reappear when you shoot, since weapons make smoke/fire). So doing something like this stops them from disappearing:

addEventHandler("onClientRender",root,
function()
local x,y,z = getElementPosition(getLocalPlayer())
fxAddDebris(x,y,z,0,0,0,0)
end
)

This effect is completely invisible so has no other impact on the game. It doesn't do anything to help the marker issue, but it's a pretty useful workaround for the weapon problem

Devan_LT

2011-06-09 21:13

viewer   ~~0013625

AFAIK, markers don't make 3D lines disappear, but move them a few hundred metres away. At least that's what happened when I used them.

ccw

2011-06-20 02:13

administrator   ~~0013731

Internally, the 3D line drawer does not set the camera matrices before rendering the lines, but rather depends on GTA leaving them set up correctly. I guess this doesn't always happen.
To fix, we need to set the camera matrices. I don't know where to fetch them from though.

arranTuna

2013-09-16 20:19

manager   ~~0019340

It doesn't seem to be a problem any more, or at least not with these DX 3D lines that were drawn in onClientHUDRender: https://dl.dropboxusercontent.com/u/7177600/mkrdx3d.jpg

Issue History

Date Modified Username Field Change