View Issue Details

IDProjectCategoryView StatusLast Update
0003389Multi Theft Auto : San AndreasGeneralpublic2008-05-04 05:23
ReporterArcAssigned ToJax 
PriorityimmediateSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0003389: Assert with setCameraTarget(getLocalPlayer())
Description

/setskin 0
/crun setCameraTarget(getLocalPlayer())

May cause an assert at CClien...ent.cpp, line 176. If it doesn't immediately assert, try entering an NRG-500 (has happened with other vehicles too, like the tractor).

TagsNo tags attached.

Activities

Jax

2008-03-25 04:29

administrator   ~~0007537

I can't reproduce it here, although I've added a possible fix in the next build, try to pinpoint the cause of this.

Arc

2008-03-25 05:03

administrator   ~~0007538

It can apparently be reliably reproduced by simply joining a battlefield69 server and spawning (asserts as soon as you click "Accept").

Arc

2008-03-26 10:00

administrator   ~~0007543

Last edited: 2008-03-26 10:03

Not fixed in March 26 build.

Edit: well, it's partially fixed at least, it happens less. E.g. it doesn't assert on Battlefield69 spawn anymore. However it still occasionally happens when entering a vehicle.

erorr404

2008-03-29 21:37

developer   ~~0007559

Last edited: 2008-03-29 21:39

Not fixed in March 29 build either. I seem to get it most of the time when I start my 'freemap', which spawns you like this:

function spawnPlayerAtSpawnpoint ( player, sp )
fadeCamera ( player, true )
setCameraTarget ( player, player )
return call ( getResourceFromName ( "spawnmanager" ), "spawnPlayerAtSpawnpoint", player, sp )
end

Jax

2008-04-01 09:55

administrator   ~~0007576

Re-test in next build

Siyo

2008-04-01 11:52

reporter   ~~0007579

I can't reproduce it with setCameraTarget anymore so I guess that was fixed. It still happens in rare cases when entering a vehicle though.

Jax

2008-04-02 06:05

administrator   ~~0007585

Moved this to debug now

Arc

2008-05-04 04:43

administrator   ~~0007676

Last edited: 2008-05-04 04:43

Reopened. It just crashes now. Integration build of May 3rd 21:36.

Code = 0xC0000005
Offset = 0x02D93001

Issue History

Date Modified Username Field Change