View Issue Details

IDProjectCategoryView StatusLast Update
0002951Multi Theft Auto : San AndreasScriptingpublic2007-12-26 10:03
ReporterjbetaAssigned ToJax 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 ~2.2GHzOSWindows XP Professional x64 SP1OS Version5.2, Build 3790
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002951: Client streamer events are not working correctly
Description

After some improvements ChrML did to streamer events, we've noticed that they don't work correctly, at least when creating elements within streamer range.

StreamIn & StreamOut events are only triggered for the first created vehicle and object, and not at all for markers and pickups.

Streaming out and back in does not fix this.

Urgent since this is breaking mouseover/click detection of collisionless elements in the editor.

Steps To Reproduce

/start map_editor
/start runcode
/crun addEventHandler("onClientElementStreamIn", getRootElement(), function() outputChatBox(tostring(source).." ["..type(source).."] streamed in") end)
/crun addEventHandler("onClientElementStreamOut", getRootElement(), function() outputChatBox(tostring(source).." ["..type(source).."] streamed out") end)

Create an element of each type, check the output.

TagsNo tags attached.

Relationships

child of 0002949 closed Map editor issues 

Activities

Jax

2007-12-26 10:03

administrator   ~~0006871

Chrml still needs to look into this.

Issue History

Date Modified Username Field Change