View Issue Details

IDProjectCategoryView StatusLast Update
0002597Multi Theft Auto : San AndreasGeneralpublic2007-10-20 13:43
Reporterlil_ToadyAssigned Tokevuwk 
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002597: getBansXML(), unbanIP()
Description

getBansXML() - to return the bans xml node,
unbanIP() - obvious (maybe unban by nick/username/serial too?)

TagsNo tags attached.

Relationships

related to 0002604 resolvedkevuwk getBansXML and unbanIP broken 

Activities

Cray

2007-10-16 04:50

viewer   ~~0005992

http://development.mtasa.com/index.php?title=UnbanIP

Talidan

2007-10-16 12:18

administrator   ~~0005993

It might be more sensible to return an array/table of bans rather than an xml node. Do whichever is best.

lil_Toady

2007-10-16 12:32

administrator   ~~0005994

i'd prefer xml node though. And it's already kept in an xml anyway. By the way this things would be cool too:

function addBan ( ip )
event onBan ( ip or maybe some table/xml node )
event onUnban ( ip )

jbeta

2007-10-17 16:54

updater   ~~0006003

I don't it's reasonable to work with xmlnodes for bans just because they're internally stored as XML. Exporting accessors for the ban list shouldn't take that long.

kevuwk

2007-10-18 13:21

administrator   ~~0006008

added getBansXML (), unbanIP existed

lil_Toady

2007-10-19 01:10

administrator   ~~0006010

what about

function addBan ( ip )
event onBan ( ip or maybe some table/xml node )
event onUnban ( ip )

?

kevuwk

2007-10-19 02:07

administrator   ~~0006011

didn't read that far down, just put resolved, will look at them later

Cray

2007-10-19 17:00

viewer   ~~0006012

Added bool banIP ( string ipToBan, [player banningPlayer = null] )

Issue History

Date Modified Username Field Change