View Issue Details

IDProjectCategoryView StatusLast Update
0002573Multi Theft Auto : San AndreasGeneralpublic2007-10-05 05:16
ReportersinnergAssigned Tokevuwk 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002573: startResource() and restartResource() only update modified client files one out of two times
Description

While /restart and /start ensure clientside resource items get updated everytime, startResource() and restartResource() need to be triggered twice.

Steps To Reproduce

/start runcode
/start mantis2573

Update the test string in mantis2573/script.lua.

/run restartResource(getResourceFromName "mantis2573")

The script won't be updated...

/run restartResource(getResourceFromName "mantis2573")

...and now it will.

TagsNo tags attached.

Relationships

related to 0002551 resolvedeAi Clientside event handlers are not always added after restarting 

Activities

Talidan

2007-10-01 18:08

administrator   ~~0005883

This is due to a bug reintroduced after 930. Probably the meta file change

jbeta

2007-10-04 20:32

updater   ~~0005913

Last edited: 2007-10-04 21:10

Doesn't seem related to meta. /gamemode calls startResource, which only updates files one out of two times.

kevuwk

2007-10-05 05:16

administrator   ~~0005915

should be fixed tonight

Issue History

Date Modified Username Field Change