View Issue Details

IDProjectCategoryView StatusLast Update
0002567Multi Theft Auto : San AndreasSynchronizationpublic2007-11-02 07:38
ReporterjhxpAssigned ToJax 
PriorityimmediateSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformPCOSWindows XP ProOS VersionSP2
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002567: Players can get desynced
Description

As above. It appears that when we were testing on cdm, some players could get desynced for others, while everything appeared fine on their screens.

See screenies. Don't mind the difference in time, as we were standing in the same place for a while.

Additional Information

http://bastage.student.utwente.nl/mta-media/desync-screenshots/arc_%20desync.png

http://bastage.student.utwente.nl/mta-media/desync-screenshots/ss-1-jhxp.png

TagsNo tags attached.

Relationships

related to 0002527 closed Player gets stuck in vehicles 
related to 0002610 resolvedJax unloading a resource desyncs players that were in vehicles related to the resource 
related to 0001483 resolvedeAi Getting sucked through Combine Harvester causes desync 
related to 0001765 resolvedChrML Vehicles randomly desync 
child of 0001672 closed Issues to be fixed ASAP! 

Activities

Talidan

2007-09-29 14:48

administrator   ~~0005846

there's probably some specific cause. any ideas?

IJs

2007-09-29 17:29

administrator   ~~0005856

Last edited: 2007-09-29 17:30

Some critical stuff to be found out:

  • When is this happening?
  • Since when is this happening?
  • How to reproduce?
  • Is it related to anything or triggered by a specific script command?

Talidan

2007-09-30 09:26

administrator   ~~0005867

Last edited: 2007-09-30 09:51

This clearly has something to do with vehicles, and the recent bugs involving delayed entry/exit. There may be another issue which produces this on foot, but it is easily reproducible using vehicles. Please note these methods will not be able to produce the effect in the screenshots above - those are on foot.

There are two ways to do this:
------------method 1-------------
The most reliable method is to get a car, and drive around at a speed whereby you cant dive out of the vehicle, yet cant get out normally since you're too slow. When you're at this speed keep tapping exit vehicle. Then stop, and you should notice you cannot exit the vehicle. This means you're desynced and stuck in a vehicle.

Everyone will see you in a vehicle, but your position isnt synced at all. Interestingly, the server and client report you at the correct position using getElementPosition (this can be noted because using 'createvehicle' creates a vehicle where you are). getPlayerOccupiedVehicle serverside returns the correct vehicle. Strangely, getPlayerOccupiedVehicle clientside returns false.

This method doesnt work so well on bikes for some reason.

------------method 2-------------
Just find a vehicle, and repeatedly spam the "enter vehicle" button over and over. This can produce two different effects:
1) You will enter the vehicle, but can no longer exit, with the exact same effect of method 1, just a different way of producing it. This also works on bikes. It should be noted that attempting to fall off your bike fails - you're forced on. However, you can be forced off by using script, which i did using setElementVelocity to the bike. Locally you'll be on foot, while remotely you'll still be in the bike
2) You will enter the vehicle, and suddenly be warped out without an anim, and remain on foot. Console debug output reports a few "Failed to enter/exit vehicle - id: 7" messages, and one "You shouldn't be in this vehicle" message. Remotely you'll appear in a vehicle, and the getPlayerOccupiedVehicle serverside will report you in a vehicle, while clientside returns false. You will no longer be able to enter any vehicles - any attempt to do so gives the console debug error of "Failed to enter/exit vehicle - id: 7".

JHXP also managed to produce a similar effect (only once) by canceling vehicle entry.

The latter of the two effects occurs less frequently, there may be some more specific technique to producing it.

All these effects can be removed by respawning, or sometimes by warping into a vehicle and exiting legitimately.

Talidan

2007-10-07 09:07

administrator   ~~0005940

This happens with interstate too. In other words, evidently warpPlayerInVehicle can cause it too.

IJs

2007-10-07 14:04

administrator   ~~0005942

It's probably another GTA bug.

Talidan

2007-10-07 14:05

administrator   ~~0005943

i dont see the logic behind that. This was introduced around a week ago. GTA bugs dont randomly introduce themselves.

Jax

2007-10-28 04:16

administrator   ~~0006080

Is this fixed now?

Talidan

2007-10-28 16:25

administrator   ~~0006084

Loads of desync in interstate on friday

Talidan

2007-10-28 21:13

administrator   ~~0006086

If you die on a vehicle (tested with /kill) the server reports you as still being on a vehicle, and you cant enter them anymore

Jax

2007-10-29 04:05

administrator   ~~0006089

It knows you're on-foot when you respawn, not sure whats going on here

Jax

2007-11-02 07:38

administrator   ~~0006119

This seems to be gone, unable to reproduce

Issue History

Date Modified Username Field Change