View Issue Details

IDProjectCategoryView StatusLast Update
0002557Multi Theft Auto : San AndreasGeneralpublic2007-11-17 10:17
ReporterjbetaAssigned Tokevuwk 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 ~2.2GHzOSWindows XP Professional x64 SP1OS Version5.2, Build 3790
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002557: Fatal error 8 on join
Description

This happened after a number of elements linked to each other through element data were created on the server. Attaching element tree dump.

TagsNo tags attached.

Activities

jbeta

2007-09-26 13:23

updater   ~~0005821

I forgot to expand edftest's elements before submitting the first dump. Here goes the complete thing.

Still can't reproduce reliably, knowing what's FE8 may help.

IJs

2007-10-06 09:26

administrator   ~~0005925

Last edited: 2007-10-06 09:28

Fatal Error 8 is raised whenever the entity name exceeds the maximum length of 255, which basically means that the packet is invalid or corrupted (caused by bad code/overflows).

The name is located right after the custom data, so that indicates an overflow of custom data.

IJs

2007-10-06 09:47

administrator   ~~0005926

Last edited: 2007-10-06 09:55

It actually seems like this is triggered whenever an element is sent that has no custom data defined.

Please try to reproduce.

jbeta

2007-10-06 13:00

updater   ~~0005931

Will do.

jbeta

2007-11-11 18:55

updater   ~~0006212

I can't reproduce this, we need feedback from other people that have had fe8 (the recent tree changes might have fixed it?).

kevuwk

2007-11-17 10:17

administrator   ~~0006326

FE8 was taken out of the code by somebody so we will assume it has been fixed

Issue History

Date Modified Username Field Change