View Issue Details

IDProjectCategoryView StatusLast Update
0002553Multi Theft Auto : San AndreasScriptingpublic2007-11-11 11:40
ReportersinnergAssigned ToCray 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002553: MAX_HEALTH stat can only be set on the CJ skin
Description

To reproduce:

start broph
start fr
setstat 24 1000

  • This will fail on any skin other than the CJ skin!

Max health doesnt seem to affect the CJ skin, so we should be able to set it on skins other than CJ (since its not visual, other then the increased amount of HP)

This prevents me from doing classes in the TFC game mode since I want to use skins for the player, so they dont look all the same (CJ)

TagsNo tags attached.

Activities

sinnerg

2007-09-26 06:02

reporter   ~~0005816

Found a workaround (so it seems) - Thanks to Solide

setskin 0 - Get the CJ skin
setstat 24 1000 - You'll get a 'larger' healthbar
setskin 7 - Switch to another skin

This way you'll keep the larger healthbar!

Talidan

2007-09-26 16:31

administrator   ~~0005824

Well yeah, that's the intention. Setting stats while not on CJ causes horrid bugs. If you think this is suitable for all scripters, close this.

jbeta

2007-09-26 16:32

updater   ~~0005825

Didn't those bugs happen when setting visual (fat, muscle) stats?

sinnerg

2007-09-26 17:02

reporter   ~~0005827

Is MAX_HEALTH to be considered visual? And as I said, setting it on CJ then switching skin it works, but I rather not use this lame workaround :P

Talidan

2007-10-15 16:22

administrator   ~~0005986

This isnt a visual stat. All this stat does is change hp bar length

eAi

2007-11-11 11:40

administrator   ~~0006191

I've changed this so it only disallows FAT and BODY_MUSCLE stats, all others can be used. Previously FAT, STAMINA, BODY_MUSCLE, MAX_HEALTH and SEX_APPEAL were disabled.

Issue History

Date Modified Username Field Change