View Issue Details

IDProjectCategoryView StatusLast Update
0002536Multi Theft Auto : San AndreasScriptingpublic2007-09-22 17:20
ReporterjbetaAssigned ToJax 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 ~2.2GHzOSWindows XP Professional x64 SP1OS Version5.2, Build 3790
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002536: createExplosion new parameters don't work
Description

Passing makeSound / camShake / damaging parameters for createExplosion doesn't have any effect (tested both clientside and serverside).

Also, clientside explosions are non-damaging by default since the params were added.

Steps To Reproduce

/start runcode
/run createExplosion(1,2,3,10) -- create a tank grenade explosion
/run createExplosion(1,2,3,10,getPlayerFromNick("<name>"),false,0,false) -- create a non-damaging one without shake/sound: won't work

Use /crun instead for clientside testing.

TagsNo tags attached.

Activities

Jax

2007-09-22 17:20

administrator   ~~0005793

Damaging arg now defaults to true, client-side syntax has no player arg, update docs!

Issue History

Date Modified Username Field Change