View Issue Details

IDProjectCategoryView StatusLast Update
0002534Multi Theft Auto : San AndreasScriptingpublic2007-11-21 07:19
ReporterslothmanAssigned ToJax 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002534: Camera position resets on setPlayerSkin
Description

when i use setPlayerSkin on a client script, the camera rotates to face north. evidentially this started a few builds ago. the player model stays facing the correct direction now, but if the players skin switches during movement it will cause the player to turn around to face the camera (very frustrating)

TagsNo tags attached.

Activities

Talidan

2007-11-11 16:48

administrator   ~~0006202

this is due to the fact that setPlayerSkin uses spawnPlayer internals now rather than actual skin setting afaik

ChrML

2007-11-18 11:45

administrator   ~~0006354

Confirmed. Our respawning causes it, just not sure how to prevent it.

Issue History

Date Modified Username Field Change