View Issue Details

IDProjectCategoryView StatusLast Update
0002509Multi Theft Auto : San AndreasScriptingpublic2007-09-16 20:32
ReporterjbetaAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 ~2.2GHzOSWindows XP Professional x64 SP1OS Version5.2, Build 3790
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002509: onClientClick only works if you enable the cursor from the server
Description

If the cursor hasn't been set visible from the server, onClientClick won't trigger.

TagsNo tags attached.

Activities

Lucif3r

2007-09-15 14:56

reporter   ~~0005721

This isnt quite right... onClientClick does trigger with clientside enabled mouse, ONCE.
After that it locks up every other click-function (new onClientClick events and onClientGUIClick)

Jax

2007-09-16 04:17

administrator   ~~0005725

Works fine here, my test script:

root = getRootElement ()

function _showCursor ( key, state, show )
showCursor ( show )
end

function onResourceStart ( resource )
if ( resource ~= getThisResource () ) then return end
bindKey ( "f1", "down", _showCursor, true )
bindKey ( "f2", "down", _showCursor, false )
end
addEventHandler ( "onClientResourceStart", root, onResourceStart )

function onClientClick ( button, state, absoluteX, absoluteY, worldX, worldY, worldZ, element )
if ( state == "down" ) then outputChatBox ( "clicked" ) end
end
addEventHandler ( "onClientClick", root, onClientClick )

jbeta

2007-09-16 10:47

updater   ~~0005729

Last edited: 2007-09-16 10:47

That script does reproduce it here, on latest nightly (0916). And for me it doesn't trigger the event at all, not even once.

btw: it's uploaded as "onclientclick" resource on test servers.

kevuwk

2007-09-16 11:21

administrator   ~~0005731

same as jax, i was unable to reproduce it, it won't say "clicked" if the console or menu is open though which is inline with the way it is coded

jbeta

2007-09-16 11:22

updater   ~~0005732

I was using the scripted cursor, not the console/menu's. So there seems to be something different with the dev and testing builds.

Jax

2007-09-16 12:08

administrator   ~~0005733

Try again in next build, 16/10/07 summoned

jbeta

2007-09-16 20:32

updater   ~~0005736

Tested, fixed.

Issue History

Date Modified Username Field Change