View Issue Details

IDProjectCategoryView StatusLast Update
0002049Multi Theft Auto : San AndreasSynchronizationpublic2007-09-06 08:00
Reportererorr404Assigned ToJax 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002049: Jetpack desynced
Description

This seems pretty rare, but sometimes when a remote player comes toward you in a jetpack you see them flying without it. It could be the way the player was streamed it.

TagsNo tags attached.

Relationships

related to 0001640 resolved Player animation desync 

Activities

IJs

2007-07-12 10:35

administrator   ~~0005086

Needs verification.

jbeta

2007-08-31 11:36

updater   ~~0005515

Couldn't reproduce it by streaming out and back in a player with jetpack, and by making a remote player stream out, get the jetpack and stream back in.

So... no idea how to make it happen, I've never even seen it.

Jax

2007-08-31 12:12

administrator   ~~0005519

This happens when they're falling or in a similar animation because we can't give them a jetpack.
We need a way to stop that animation first.. and force a jetpack on them! :p

jbeta

2007-09-05 12:25

updater   ~~0005617

Last edited: 2007-09-05 12:32

Could be related to the task issue from #1640.

After getting it as described in ~5616, making the affected player add a jetpack wouldn't show it for players observing TASK_COMPLEX_IN_AIR_AND_LAND in the affected player's actor:

jhxp's tasks [locally for jbeta]:
Primary tasks:

  • TASK_PRIORITY_EVENT_RESPONSE_TEMP[1]: TASK_COMPLEX_IN_AIR_AND_LAND
  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

jhxp's tasks [locally for jhxp]:
Primary tasks:

  • TASK_PRIORITY_PRIMARY[1]: TASK_SIMPLE_JETPACK
  • TASK_PRIORITY_DEFAULT[1]: TASK_SIMPLE_PLAYER_ON_FOOT
    Secondary tasks:
  • TASK_SECONDARY_FACIAL_COMPLEX[1]: TASK_COMPLEX_FACIAL

Jax

2007-09-06 08:00

administrator   ~~0005628

This should be fixed now, if not, find out when giving a jetpack to a player (even locally) doesn't work

Issue History

Date Modified Username Field Change