View Issue Details

IDProjectCategoryView StatusLast Update
0001965Multi Theft Auto : San AndreasScriptingpublic2007-04-15 05:35
Reportererorr404Assigned ToJax 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001965: Crash when moving element out too far from player/camera [0x07B39FB1]
Description

If you use client setElementPosition on an elem and it is too far away from your players position or the camera's position (not sure which, it looks like the point where elements are streamed out), then you get this crash.

Steps To Reproduce

Start ME_404 resource (make sure drag_fixed.lua and drag_fixed_server.lua are part of it), then click and drag a vehicle far away from the camera along the ground.

Additional Information

2007-4-15 4:42:45 Crash ID: 29766 Address: 0x07469FB1
2007-4-15 4:43:46 Crash ID: 29767 Address: 0x07969FB1
2007-4-15 4:57:13 Crash ID: 29768 Address: 0x05B49FB1
2007-4-15 5:4:15 Crash ID: 29769 Address: 0x073C9FB1
2007-4-15 5:8:12 Crash ID: 29770 Address: 0x05349FB1
2007-4-15 5:11:56 Crash ID: 29771 Address: 0x07B39FB1
2007-4-15 5:19:20 Crash ID: 29772 Address: 0x05349FB1
2007-4-15 5:35:2 Crash ID: 29774 Address: 0x05359FB1
2007-4-15 5:38:26 Crash ID: 29775 Address: 0x05359FB1
2007-4-15 5:40:29 Crash ID: 29776 Address: 0x05359FB1
2007-4-15 5:41:58 Crash ID: 29777 Address: 0x07B39FB1

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change