View Issue Details

IDProjectCategoryView StatusLast Update
0001947Multi Theft Auto : San AndreasScriptingpublic2007-04-14 12:15
ReporterslothmanAssigned ToJax 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Version 
Summary0001947: server crash / protocol 150
Description

this script is meant to spawn a marker and a bliponly visable to a player who walks into a certain marker.

the blip and secondary marker shows to everyone however. also, when the script is stopped, the person who walked into the first marker gets booted off the server and given a protocol 150 message. on top of that, on occasion it will totally crash the server. all the output chatbox stuff does show up before the crash occurs however.

we beleive its related to the setElementVisibleTo lines.

Additional Information

HERE IS THE LUA CODE:

truckertriggermarker = createMarker ( -77.69, -1136.22, 1.07, "cylinder", 1.5, 255, 255, 0, 170 )

addEventHandler ( "onMarkerHit", getRootElement(), "truckertriggermarkerhit" )
function truckertriggermarkerhit ( hitplayer )
truckertargetmarker = createMarker ( 2739.59, -2465.75, 13.64, "cylinder", 6, 255, 255, 0, 170 )
truckertargetblip = createBlip ( 2739.59, -2465.75, 13.64, 53 )
bigtruck = createVehicle ( 403, -60.40, -1131.94, 1.68, 0, 0, 66.10 )
trailer = createVehicle ( 584, -53.40, -1134.94, 1.68, 0, 0, 66.10 )
outputChatBox ( "WORKING POINT 1" )
attachTrailerToVehicle ( bigtruck, trailer )
destroyElement ( truckertriggermarker )
outputChatBox ( "WORKING POINT 2" )
local players = getElementsByType ( "player" )
for k,v in players do
setElementVisibleTo ( truckertargetmarker, v, false )
setElementVisibleTo ( truckertargetblip, v, false )
end
outputChatBox ( "WORKING POINT 3" )
setElementVisibleTo ( truckertargetmarker, hitplayer, true )
setElementVisibleTo ( truckertargetblip, hitplayer, true )
end

TagsNo tags attached.

Relationships

related to 0001650 closed Ring markers disappear / go invisible on hit 
related to 0001724 resolvedIJs crash on mapload [0x7C910F29 - 20377, 20378] 

Activities

IJs

2007-04-14 10:37

administrator   ~~0004362

150 occurs when you're attempting to remove an element that isn't valid.

IJs

2007-04-14 10:39

administrator   ~~0004363

Last edited: 2007-04-14 10:39

When you're stopping a resource it removes all the elements associated with that resource, so it's predicted behaviour.

Apparently the marker doesn't get deleted from the game or something.

Jax

2007-04-14 11:25

administrator   ~~0004369

Think this was due to mismatching packet-data, should be fixed, but reopen if it happens again.

Issue History

Date Modified Username Field Change