View Issue Details

IDProjectCategoryView StatusLast Update
0001745Multi Theft Auto : San AndreasGeneralpublic2007-05-05 09:03
ReporterBB101Assigned ToIJs 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Version 
Summary0001745: Crash on duplicate CEGUI element id's
Description

I always crash when spamming changeskin (somewhere between 100 and 200 times) debug error, no crash report, whoever i noticed the CEGUI logs are exact same bit size, so it could be a limit hit, ends as follow, complete logs attached

Additional Information

19/12/2006 18:09:51 (InfL2) Window 'ù' has been added to dead pool.
19/12/2006 18:09:51 (InfL2) Window 'ü' of type 'CGUI/StaticImage' has been created.
19/12/2006 18:09:51 (InfL2) Assigning LookNFeel 'CGUI/StaticImage' to window 'ü'.
19/12/2006 18:09:51 (InfL1) Attempting to create Imageset 'ý' with texture only.
19/12/2006 18:09:51 (InfL2) Window 'ü' has been added to dead pool.
19/12/2006 18:09:51 (InfL2) Window 'ÿ' of type 'CGUI/StaticImage' has been created.
19/12/2006 18:09:51 (InfL2) Assigning LookNFeel 'CGUI/StaticImage' to window 'ÿ'.
19/12/2006 18:09:51 (InfL1) Attempting to create Imageset '' with texture only.
19/12/2006 18:09:51 (Error) Exception: ImagesetManager::createImageset - An Imageset object named '' already exists.

TagsNo tags attached.

Relationships

related to 0001213 closed Crash whilist changing the skins 
has duplicate 0001303 closedChrML Changing a lot of skins causes a crash after a while 
has duplicate 0001192 resolvedIJs Crash - not sure of exact details 

Activities

erorr404

2006-12-19 15:27

developer   ~~0003805

Crash on skin change has already beedn reported, but this could be related to spawning and not changing skins (as you respawn when you change skin).

BB101

2006-12-19 16:28

reporter   ~~0003806

Meh my bad, forgot to search, anyway as there is now, is it possible to change skin without respawn? since i was just flooding with one skin, so it may very well be spawning

IJs

2006-12-23 13:37

administrator   ~~0003823

This is indeed CEGUI related.. you just ran out of id's for new chatbox lines.

IJs

2006-12-23 13:38

administrator   ~~0003824

Thanks for log. I thought I fixed this issue a month ago.

Issue History

Date Modified Username Field Change