View Issue Details

IDProjectCategoryView StatusLast Update
0001677Multi Theft Auto : San AndreasGeneralpublic2006-11-27 10:27
ReporterRansomAssigned ToJax 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001677: automatic weapon switch toggle?
Description

Can something toggle this from happening? Not good to lose your gun for a chainsaw sometimes.

TagsNo tags attached.

Activities

Jax

2006-11-17 04:22

administrator   ~~0003648

cancelEvent works for both pickupHit events

erorr404

2006-11-17 14:13

developer   ~~0003649

Why do you resolve it instead of closing it? :S

Jax

2006-11-18 06:13

administrator   ~~0003652

Cause i added cancelEvent, it wasnt there already :P

Ransom

2006-11-19 01:34

administrator   ~~0003653

Last edited: 2006-11-19 01:36

This is not what I meant, I'm not talking about not picking up a weapon. I mean not actually switching to the weapon automatically. For instance, if you have an ak47 and you go for a satchel pickup, you probably dont want to use it right then. But, you wanted the pickup because its very valuable to use later.

I think what I'm asking for here is a forceEquip function under weapons category.

Talidan

2006-11-21 15:23

administrator   ~~0003659

i agree with ransom here.

id like to see giveWeapon not forcing switch, and a setPlayerWeapon function

Jax

2006-11-27 10:27

administrator   ~~0003679

Added a setAsCurrent bool to giveWeapon and pickups shouldn't change it anymore

Issue History

Date Modified Username Field Change