View Issue Details

IDProjectCategoryView StatusLast Update
0001634Multi Theft Auto : San AndreasGeneralpublic2008-01-05 17:12
Reportererorr404Assigned ToJax 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001634: Long pause from taking first screenshot
Description

I get a 5-10 seconds pause when taking the first screenshot after starting MTA. Subsequent screenshots take around 1 second. And no my PC is not that shitty: P4 3.2 GHz, 1.5 GB RAM, 6600 GT graphics.

TagsNo tags attached.

Activities

IJs

2006-12-10 14:28

administrator   ~~0003745

JPEG initialisation

IJs

2006-12-10 14:50

administrator   ~~0003746

However, we're using an internal function to do this so I'm not sure whether there's much we can do without rewriting the function ourselves. It doesn't seem trivial enough at this point.

Talidan

2006-12-10 15:36

administrator   ~~0003757

Well for starters the screenshot capture isnt very good anyway - it just takes a screen dump rather than a shot of MTA. This means in windowed mode you'll have a shot of desktop. Fraps is still the way to go for me.

If jpeg takes so long, why not use .BMP? id rather sacrifice disk space for speedier snap taking

IJs

2006-12-10 17:55

administrator   ~~0003763

Last edited: 2006-12-10 17:56

As I've said we're using a GTA function to do this.. not our own one like in MTA:VC. This is not a major issue.. probably something for the future. We should save in .PNG format anyways cause its superior.

jbeta

2007-03-21 19:24

updater   ~~0004200

It's saving in PNG now.

erorr404

2007-05-30 01:21

developer   ~~0004667

I get this again now, since the past few builds.

norby89

2007-12-31 04:55

updater   ~~0006948

lately I have this and it's pretty bad, I get 10-30 second freezes

norby89

2008-01-02 12:36

updater   ~~0006982

looks like it's fixed

Issue History

Date Modified Username Field Change