View Issue Details

IDProjectCategoryView StatusLast Update
0001615Multi Theft Auto : San AndreasSynchronizationpublic2006-10-20 18:17
Reportererorr404Assigned ToJax 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001615: Incorrect positions for remote players
Description

When players get far enough away from eachother, their positions aren't reported properly most of the time. You may see the player on foot at a random (?) location, though they are actually in a vehicle somewhere else. I don't know if this issue only happens with vehicles. When players stream in to eachother, their positions are shown correctly.

Additional Information

This issue was fixed a couple of weeks ago, but re-surfaced in the past few builds along with some other nasty bugs (such as remote player positions flickering from place to place when in a vehicle). Those new bugs were fixed in build 1016, but the old 'desync on stream out' issue remained.

TagsNo tags attached.

Activities

erorr404

2006-10-17 23:22

developer   ~~0003577

Me and Vandalite were playing today and it almost certainly has to do with vehicles.

When the desync occurs, you see the remote player at the position where they last entered the vehicle. When this happens their vehicle appears to be driving by itself, so the vehicle is synced but not the player. I could tell because I was a passenger in Vandalite's helicopter and when the desync occured, he disappeared to the position where he entered the heli and the engine shut off (blades stopped spinning), but the heli was still flying.

Vandalite

2006-10-19 23:30

updater   ~~0003581

Error and i just tested it, and it seems it's still not fixed. easily reproducable too. happens if you drive far enough away from the point where you entered your vehicle.

erorr404

2006-10-20 18:17

developer   ~~0003587

Fixed in build 1021.

Issue History

Date Modified Username Field Change