View Issue Details

IDProjectCategoryView StatusLast Update
0001566Multi Theft Auto : San AndreasGeneralpublic2007-05-02 11:34
Reportererorr404Assigned ToIJs 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Version 
Summary0001566: Major pauses for all players
Description

During our 5+ people test today, we started experiencing frequent pauses, where the screen stops for a fraction of a second.

I know that these always occur when someone dies or when someone joins the game.

Other times it seems to happen for no reason at all. At one point they started happening every second or so and it became unplayable. I wasn't around anybody at the time so it wasn't due to fps lag. We had to restart the map in order to fix this.

TagsNo tags attached.

Relationships

related to 0001987 closed Add efficient lazy model loading 

Activities

JonChappell

2006-09-21 20:28

manager   ~~0003512

I experienced this as well, but I thought it was my PC. I lowered the resolution and it still did it.

erorr404

2006-09-21 22:11

developer   ~~0003513

If anyone that was playing that night remembers what they were doing when those heavy pauses started happening, please share. eAi said that changing clothes can also cause this lag.

JonChappell

2006-10-11 14:40

manager   ~~0003557

Apparently this is something to do with clothing.

erorr404

2006-10-16 18:33

developer   ~~0003571

There is now a big pause when players spawn (I think it was present before but was fixed).

erorr404

2006-10-24 21:44

developer   ~~0003592

We need to organize a test with as many people as we can, and with devs present, so they can debug this.

IJs

2006-12-23 13:59

administrator   ~~0003828

Please try and test if, at the moment of the slowdown, there is any GUI activity (new chat lines), etc.

IJs

2007-01-20 16:35

administrator   ~~0003906

And monitor the pings.

IJs

2007-01-21 19:04

administrator   ~~0003976

This has been happening frequently server-side too: no chat response and player movement (or fixed player movement) for about 3 seconds every 1 or 2 minutes. Not sure if it's caused by some resource.

IJs

2007-01-22 11:56

administrator   ~~0003996

My report is related to CRC checksum code, probably.

erorr404

2007-02-04 05:50

developer   ~~0004018

To test this properly, we'll need to get 6+ people into the server at once and have them do all sorts of stuff. Then we can pin down the causes better.

IJs

2007-02-24 07:08

administrator   ~~0004062

Please check if this is fixed, may be related to server-side resource caching (thus already fixed)... and were these freezes renderer freezes or lag spikes?

kevuwk

2007-02-24 08:52

administrator   ~~0004065

i have seen this recently on the koth resource by talidan where a timer messes up a little, starts giving loads of errors and i had pauses every second or so

IJs

2007-03-04 14:10

administrator   ~~0004119

That's normal behaviour with CEGUI in debug mode. A lot of GUI activity means a significant performance degradation.

erorr404

2007-03-04 18:21

developer   ~~0004122

The GUI may be one of the causes, but this was also caused by changing clothes, players spawning, players joining, and other things we haven't discovered yet.

IJs

2007-03-28 19:50

administrator   ~~0004256

Which all output to the GUI. I know the GUI can take 0.2 seconds of processing time before outputting a chat line.

IJs

2007-04-17 16:53

administrator   ~~0004398

This needs to be re-tested, as the chatbox is rewritten.

IJs

2007-05-02 11:33

administrator   ~~0004445

Last edited: 2007-05-02 11:34

Caused by the currently blocking model loading.

Issue History

Date Modified Username Field Change