View Issue Details

IDProjectCategoryView StatusLast Update
0001542Multi Theft Auto : San AndreasScriptingpublic2006-09-04 09:34
Reportererorr404Assigned ToJax 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a11.1 
Target VersionFixed in Version 
Summary0001542: cloneElement should use coordinates instead of offsets
Description

element cloneElement ( element theElement, [ float xOffset = 0, float yOffset = 0, float zOffset = 0, bool cloneChildren = false ] )

It doesn't make sense to have the position be an offset, as it would be troublesome to specify a known location.

Instead it should accept coordinates. It would still be easy to specify an offset by just getting the original elements coords.

TagsNo tags attached.

Activities

Jax

2006-09-04 08:54

administrator   ~~0003436

It uses an offset because of the option to clone the children, it doesn't make sence to clone a group of elements and have them all in the same place.

Jax

2006-09-04 09:34

administrator   ~~0003438

Changed it to use the position as an offset, only if cloneChildren is used.

Issue History

Date Modified Username Field Change