View Issue Details

IDProjectCategoryView StatusLast Update
0001475Multi Theft Auto : San AndreasGeneralpublic2006-08-15 15:09
Reportererorr404Assigned ToChrML 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a11.1 
Target VersionFixed in Versionblue_sa.r2.a12 
Summary0001475: Strange crash on server join
Description

When I join Solide's server the game crashes at the Verifying Client dialogue and produces a MS Visual C++ Runtime Library error message:
http://www.thegamersalliance.com/screens/MTAMSVCcrash.jpg

Hitting Abort or Ignore does nothing, hitting Retry closes the game and creates an error report:

2006-7-12 1:39:41 Crash ID: 9544 Address: 0x06EE649D
-- Unhandled exception --
Time = Tue Jul 11 18:39:38 2006
Code = 0x80000003
Offset = 0x06EE649D
EAX=00000004 EBX=06EF3617 ECX=7C91056D EDX=00770000 ESI=00000001
EDI=06F58998 EBP=0022F418 ESP=0022F0E4 EIP=06EE649D FLG=00200246
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000
-- End of unhandled exception --

2006-7-12 1:43:2 Crash ID: 9545 Address: 0x06EF649D
-- Unhandled exception --
Time = Tue Jul 11 18:42:57 2006
Code = 0x80000003
Offset = 0x06EF649D
EAX=00000004 EBX=06F03617 ECX=7C91056D EDX=00760000 ESI=00000001
EDI=06F68998 EBP=0022F418 ESP=0022F0E4 EIP=06EF649D FLG=00200246
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000
-- End of unhandled exception --

TagsNo tags attached.

Activities

erorr404

2006-07-12 02:53

developer   ~~0003315

Btw I don't know what causes this.. I leave the server with no problems, come back later and it's down. Restarting the server fixes it.

Oli

2006-07-12 05:59

administrator   ~~0003316

are yopu creating any radar icons?

erorr404

2006-07-12 12:42

developer   ~~0003320

The default one (id 0), yes.

BlueZircon

2006-07-12 19:52

viewer   ~~0003326

Last edited: 2006-07-12 19:54

I got the same crash earlier:

-- Unhandled exception --

Time = Wed Jul 12 19:46:55 2006
Code = 0xC0000005
Offset = 0x093CF670

EAX=03649788 EBX=00000000 ECX=00000000 EDX=093E2D3C ESI=0364A008
EDI=03649960 EBP=00000000 ESP=0022F5A4 EIP=093CF670 FLG=00210206
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

-- End of unhandled exception --

-- Unhandled exception --

Time = Wed Jul 12 19:47:28 2006
Code = 0x80000003
Offset = 0x093D649D

EAX=00000004 EBX=093E3617 ECX=7C91056D EDX=00DD0000 ESI=00000001
EDI=03658890 EBP=0022F418 ESP=0022F0E4 EIP=093D649D FLG=00200246
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

-- End of unhandled exception --

The first one is a crash where I simply exited a vehicle after erorr404 and I were testing out the trailers, and the next was when I tried to rejoin and got a runtime error.

erorr404

2006-07-26 23:34

developer   ~~0003381

Makes this alpha really hard to test..

Talidan

2006-07-29 13:42

administrator   ~~0003397

I think this is something to do with vehicles that are created.

What is odd is that players inside will have their game working fine but people joining will get this error.

The reason i think it is vehicles is because a map restart solves the problem

erorr404

2006-07-30 03:53

developer   ~~0003399

Might be related to trailers. We were messing around with them, then all crashed and couldn't connect to the server any longer.

2006-7-30 8:40:44 Crash ID: 10987 Address: 0x06ECF670

-- Unhandled exception --

Time = Sun Jul 30 01:40:37 2006
Code = 0xC0000005
Offset = 0x06ECF670

EAX=06F4D528 EBX=00000000 ECX=00000000 EDX=06EE2D3C ESI=06F4E608
EDI=06F4D718 EBP=00000000 ESP=0022F5A4 EIP=06ECF670 FLG=00210206
CS=001B DS=0023 SS=0023 ES=0023 FS=003B GS=0000

-- End of unhandled exception --

ChrML

2006-07-31 13:39

administrator   ~~0003409

Don't worry about this. This is really a protocol error but a11 was compiled wrongly so it raised a Debug exception instead in Release mode.

Talidan

2006-08-15 15:09

administrator   ~~0003419

but if its still a protocol error its still a problem

Issue History

Date Modified Username Field Change