View Issue Details

IDProjectCategoryView StatusLast Update
0001293Multi Theft Auto : San AndreasGeneralpublic2009-02-07 20:05
Reportererorr404Assigned ToTalidan 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a6 
Target Version1.0Fixed in Version1.0 
Summary0001293: Sync parachutes
Description

Right know they don't open.

TagsNo tags attached.

Relationships

child of 0001171 closed Feature requests Tracking Issue 

Activities

Solide

2006-05-25 15:43

reporter   ~~0003099

Last edited: 2006-05-25 15:45

Bumpy. This is rather important IMO.

Ransom

2006-06-05 20:54

administrator   ~~0003126

Pretty sure this is delayed until after 1st release

Talidan

2006-06-23 19:57

administrator   ~~0003236

i was thinking.

If we had moveentity in lua, and say binds for buttons, and some sort of function to force an animation.

Surely after jumping, you could get the velocity, if its x then force the animation of sky diving, and it moves the entity when you press WSAD. when you click it forces the parachute position, and creates the parachute as an object and attatches the entity to the player. WSAD can be used to move entity here too. When he hits the ground it stops forcing the animation and destroys the parachute object.
This wouldnt look perfect, i.e. the player wouldnt lean while jumping for example, but would still work okay.

Now, if this was done clientside it could be done MUCH more efficiently. i cant see it being that difficult if you simply move the player as mentioned above and use the fire button as a trigger, the parachute can be created as an object serverside. It may not replicate the single player chute visually 100%, but i think it will function all the same.

scarface1994

2009-02-07 19:57

viewer   ~~0008343

Shouldn't this be set to resolved(Talidan) since this could be done by script, and has already been done by Talidan.

Talidan

2009-02-07 20:05

administrator   ~~0008344

Yep. Use "parachute" resource provided in latest svn

Issue History

Date Modified Username Field Change