View Issue Details

IDProjectCategoryView StatusLast Update
0001249Multi Theft Auto : San AndreasGUI / Menus / Consolepublic2006-06-05 17:13
ReporterBlueZirconAssigned ToChrML 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a5 
Target VersionFixed in Versionblue_sa.r2.a10.3 
Summary0001249: The ping on the scoreboard shouldn't refresh so often
Description

It refreshes at least twice a second, which is too much, I think.

Why not have it refresh like it did in MTA: Vice City (about once per two seconds)?

Unless, of course, there's a reason it does this.

TagsNo tags attached.

Activities

ChrML

2006-04-16 16:47

administrator   ~~0002898

It refreshes more often as we need accurate pings for our new ping compensation code on shooting, though twice a second might be too often.

ChrML

2006-04-16 16:48

administrator   ~~0002899

Actually, no. It depends on the number of players. If you're the only one, you get one twice a second, if there are 10 players, you get one each 5th second.

BlueZircon

2006-04-16 18:01

viewer   ~~0002900

Wouldn't being pinged constantly like that cause you to lag more?

Oli

2006-04-17 06:13

administrator   ~~0002907

actually chrml i rewrote this.. its twice a second regardless of players atm (unless uve changed it since i did).

No zircon.. twice a sec of tiny ping packets is nothing compared to the pure/key sync

ChrML

2006-04-17 07:21

administrator   ~~0002909

I'll change it to once a second so it's only 32 packets a second for a busy server with 32 players.

Oli

2006-04-17 10:03

administrator   ~~0002913

maybe we should just dump it all in 1 packet?

ChrML

2006-06-05 17:13

administrator   ~~0003122

Players will receive pinglists every 3 seconds now regardless of the playercount.

Issue History

Date Modified Username Field Change