View Issue Details

IDProjectCategoryView StatusLast Update
0001220Multi Theft Auto : San AndreasGeneralpublic2007-05-26 17:35
Reportererorr404Assigned ToJax 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001220: Invisible player
Description

I was playing with Slothman earlier today and saw his player model disappear a couple of times, leaving only his nametag visible. Everything was synchronized properly, only his player model was missing. He had a pedestrian skin on at the time.

Additional Information

http://thegamersalliance.com/Th!s_is_N0T_hidden_dir/mta-screen0213.png

TagsNo tags attached.

Activities

erorr404

2006-04-16 03:18

developer   ~~0002885

Also seen it happen with Zircon the other day, I think he was in a hydra and it was invisible. Don't think that case had anything to do with skin change.

jhxp

2006-04-22 15:29

administrator   ~~0002957

IJs was invisible for me, while he was in a plane (only nametag visible).

Earlier today, mack was invisible too while he was on foot.

Talidan

2006-05-24 15:30

administrator   ~~0003092

i think this got fixed a long time ago..

erorr404

2006-05-24 15:32

developer   ~~0003094

Yeah I haven't witnessed it recently, but do you know for sure?

jhxp

2006-05-25 05:26

administrator   ~~0003098

Talidan, don't you remember when it happened today? :)
Might be a different cause, but same effect, instead that you were invisible locally too.

erorr404

2007-05-07 02:09

developer   ~~0004536

Happened to me the other day when we were playing 'ctv' and I warped to the location of the other players.

BrophY

2007-05-07 05:29

updater   ~~0004539

This is caused by the camera functions, if its set to fixed, then you spawn without the camera being set back to player, then they will appear invisible, ctv should be fixed today, gotta add the ipairs thing to the script

jbeta

2007-05-22 13:45

updater   ~~0004602

It's not really fixed right now, should be if possible.

Jax

2007-05-23 05:28

administrator   ~~0004613

So is this a script problem?

BrophY

2007-05-23 12:38

updater   ~~0004614

its fine if people remember to revert it onResourceUnload and other events

jbeta

2007-05-23 14:03

updater   ~~0004615

IMO, that counts as a fix only if you're certain that there is no way to prevent it from MTA.
Why not make spawning funcs set camera mode back to "player" automatically?

Jax

2007-05-23 16:26

administrator   ~~0004616

Cause you might not want that

BrophY

2007-05-24 04:27

updater   ~~0004618

get the same with the set dimension function tbh, make sure there is a check in your script for that too

slothman

2007-05-26 17:35

updater   ~~0004636

after warping into a vehicle from far away, other people let me know they couldnt see me driving, but saw the car moving. this was in the 20070526 build.

Issue History

Date Modified Username Field Change