View Issue Details

IDProjectCategoryView StatusLast Update
0001193Multi Theft Auto : San AndreasGeneralpublic2007-11-18 08:47
ReporterTalidanAssigned ToChrML 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a4 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001193: Glitch to potentially warp you back to car or give you infinite ammo
Description

Do the following:
Go near a car, and go into aim mode. Then press enter to enter the car. The player will now move around faster than he normally would in aiming mode and you can control it.

I have found that sometimes pressing the shoot button will cause the character to shoot server side (you will not see it on your screen but others do, therefore giving infinite ammo). I cannot reproduce this reliably.

When you are in this aim mode, you will also warp (well, move VERY fast) back to your car from great distances and get in. This is abusable for obvious reasons, though i cant reproduce it reliably

I suspect this bug exists in SP too, but its something that should be addressed.

Chrml mentioned something about stopping the player from getting into a car while in aim mode, which should work. however, if the enter button is blocked entirely it would stop any alternative attacks (attacks that you learn in dojos or gyms etc - if they are synced in future)

TagsNo tags attached.

Activities

Talidan

2006-04-09 16:26

administrator   ~~0002832

i also forgot to mention that when you do this it causes the player to warp a lot serverside, so it makes it harder for people to shoot him

Talidan

2006-06-16 19:27

administrator   ~~0003216

still exists

Talidan

2006-06-24 12:37

administrator   ~~0003245

still here in a10

Talidan

2006-07-20 10:04

administrator   ~~0003352

Last edited: 2006-07-20 10:05

Appears to be fixed in a11.1...maybe due to the keybinds system which actually fixed another SP bug

Talidan

2006-09-21 13:20

administrator   ~~0003509

this wasnt resolved - i just thought it was. Its still producable and more dangerous.

To do it now, you have to press enter vehicle then press aim REALLY fast.

before, the player would warp around to his real position - now it appears remotely that the player has entered the car but he isnt really. this means the player can sneak behind an enemy and kill him undetected

jbeta

2007-03-22 19:56

updater   ~~0004207

Does it still happen? I can't reproduce it.

Talidan

2007-03-30 13:48

administrator   ~~0004274

reproducable as 30/3/07.

Talidan

2007-03-31 18:50

administrator   ~~0004276

still here, as of 01/04/07. not fixed properly

Jax

2007-04-01 08:35

administrator   ~~0004281

Finally fixed!

Talidan

2007-11-17 20:52

administrator   ~~0006347

Back from the dead :)

ChrML

2007-11-18 08:47

administrator   ~~0006352

Resolved. Can't happen locally nor remotly anymre.

Issue History

Date Modified Username Field Change