View Issue Details

IDProjectCategoryView StatusLast Update
0009809Multi Theft Auto : San AndreasMulti Theft Auto : San Andreaspublic2018-01-26 01:04
ReporterseelrdAssigned Toccw 
Status resolvedResolutionfixed 
Product Version 
Target Version1.5.6Fixed in Version1.5.6 
Summary0009809: Random clients/players crash when joining our server


Random players crash during connecting to our server with the following crash message:
ersion = 1.5.5-release-11839.0.000
Time = Wed Jan 24 20:58:38 2018
Module = C:\Games\GTA_San_Andreas\Grand Theft Auto - San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x0032837D

EAX=00000005 EBX=00000015 ECX=FFFFFFFF EDX=000000FF ESI=0000006D
EDI=00000014 EBP=00C80402 ESP=0177FC78 EIP=0072837D FLG=00010206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

I opened this bug report because this is really important for us as we have a popular server and we don't want our players not to be able to play at us.
Thank you!

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 1

2018-01-24 23:19: seelrd (EUR 1)
Users sponsoring this issue (Total Sponsorship = EUR 1)



2018-01-25 00:18

administrator   ~~0026402

What is the server IP/port ?


2018-01-25 00:19

viewer   ~~0026403


2018-01-25 19:05

viewer   ~~0026404

That's the core.dmp file. I hope it helps.


2018-01-25 19:42

viewer   ~~0026405

And crashdump


2018-01-25 20:10

administrator   ~~0026406

It looks related to radar blips. Does your server use custom blips?


2018-01-25 20:18

viewer   ~~0026407

It uses createBlip, but with custom icons on a custom radar.


2018-01-25 20:26

viewer   ~~0026408

We stopped a resource that used addAttachedBlip exported function, new core.dmp:


2018-01-25 20:59

administrator   ~~0026409

The crash is caused by calling createBlip or createBlipAttachedTo with an icon value larger than 63.
Reproducible with: for i=64,255 do createBlip(0,0,0,i) end

MTA will be fixed to handle the out of range values. Until then, you will have to check each call to createBlip or createBlipAttachedTo


2018-01-25 21:09

viewer   ~~0026410

Thank you very much! That solved the problem.

Issue History

Date Modified Username Field Change