View Issue Details

IDProjectCategoryView StatusLast Update
0009515New issuesMulti Theft Auto : San Andreaspublic2016-12-29 15:17
ReporterAfterAll14Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformWindowsOSWindowsOS Version7
Summary0009515: OOP usage creates memory leaks
Description

Leaks are quite big. On my computer 100K cycle loop creates ~20MB leak, so about 10 million created objects may kill the system (which is not very much if you run it in cycles).
For instance: dat thing in conjuction with 3D radar (created by Ren712), which uses OOP intensively in "onClientRender" cycle, kills my laptop with 2GB RAM in about 15-20 mins.
"works" both on client and server.

Steps To Reproduce

for i = 1, 100000 do
local V1 = Vector3(1,1,0)
end
---> each cycle will result in about 17MB of leaked memory in ipb on server and ~20MB leak in task manager for process "gta_sa.exe"
---> collectcarbage does nothing on server, on client it partially neutralizes leaks, but memory tends to grow rapidly all the time as well

Additional Information

Idk if this was reported before (I couldn't find any reports). Seems like quite a major problem to me as, so marked it "major".

TagsNo tags attached.

Relationships

duplicate of 0009480 closedccw Multi Theft Auto : San Andreas Memory leak when using Vector3 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change